SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello, I'm new to this forum....I recently bought a 2005 Saab 9-3 and it's really nice. Two days ago it was pouring and I forgot to put up my window (driver's side). I didn't think much water got in but the next morning my radio wasn't working, the dash is just a black screen, there's no sound coming from the radio, even the 'clicking' noise when I turn on my blinker lights is gone. Other than that the car seems fine. I did some research and found out the amplifier is under the driver's seat and the fact that it got wet could of caused the problem. Has this happened to anyone else? I want to know if I need a new amplifier...will it fix the problem or is it something else?
 

·
Registered
Joined
·
980 Posts
Back in June of 2006, when my car was 4 months old, I opened the door quickly to get out of the car during a torrential rain and that fried my AMP1. No tunes, no blinker sounds, etc. I was fortunate that it was replaced under warranty. So yes, that is likely what has happened to yours. Hopefully you can find a good used one for a reasonable price.

A single torx screw in the rear holds it in place but the connector on the side is tricky to work with due to limited space. There are optical cables in that harness so treat it gently. If needed, remove the two torx screws that hold the seat in place and tip the seat forward to give more space for your hands to deal with the connector.
 

·
Super Moderator
Joined
·
19,646 Posts
Yup, fried amplifier.
 
1 - 3 of 3 Posts
Top