SaabCentral Forums banner
1 - 20 of 51 Posts

·
Registered
Joined
·
22,211 Posts
Discussion Starter · #1 ·
Breathe deeply, in with love out with anger.....................

Now my interior fan has stopped working, recalibration shows no problems, but no fan, absolutely nothing, the fuse is fine :roll:

New fan then???

Any other ideas?

Cheers Chris
 

·
Registered
Joined
·
22,211 Posts
Discussion Starter · #3 ·
Ok I'm on it ;)


Give me two mins :cool:
 

·
Registered
Joined
·
22,211 Posts
Discussion Starter · #5 ·
Guess what :p



Swapping done and...............



Nothing :cry:
 

·
Registered
Joined
·
22,211 Posts
Discussion Starter · #7 ·
There are about four in there at are listed as fans, high fan, low fan, any bloody fan will do me :roll:
 

·
Registered
Joined
·
22,211 Posts
Discussion Starter · #9 ·
Erm, kinda :confused:


Hey lets hope that before it died it made a strange noise from cold like a blade of grass being blow through :lol:
 

·
Registered
Joined
·
11,030 Posts

Thought i'd help out a bit....part no 4635462 superceded by part no 5331236. Price is £156.10 at Euro-saab-parts.
 

·
Registered
Joined
·
11,030 Posts
If you look at the task bar on the pictures you'll see a red Saab griffon with the letters EPC, its the Saab Electronic Parts Catalogue. :cool:
 

·
Registered
Joined
·
44 Posts
My fan stopped without warning too

My fan stopped yesterday too. The display on the dash still is showing everything (auto, lo, etc...) but not blowing. Will the relay on 1999 9-5 4 cyl turbo be the same as the ones you describe? Is it in engine compartment too? If not that, is the fan that you show accessible and easy enough for me to replace?
 

·
Registered
Joined
·
22,211 Posts
Discussion Starter · #14 ·
Thats the same as mine, the display shows it working but it doesnt :roll: Yes the relays are in the same place ;)

Apparently its a 50% chance its the resistor and 50% chance its the fan, here are the instructions I got to find out which it might be:

On you heater motor it could be the resistor, I would guess we are seeing 50/50, if you take of the bulkhead cover with a wiper arm puller, you will see the 2 wires going to the fan motor, either unplug it and make up a small loom to put a direct feed and earth from the battery, and if the motor runs its the resistor, or check to see if you have power and earth to the plug, again unplug the connector and connect the plug to a headlight bulb, with the ignition on you should be able to make the bulb go brighter and diimer as you change the fan speed, if you can it means the motor is at fault.

Thanks to Wessy for these instructions which I havent tried yet, getting the wiper arms off will be tough :roll:
 

·
Registered
Joined
·
44 Posts
Trouble shooting my fan in 1999 9-5

I took Kermit's first advice at lunch break and went out and pulled relay, cleaned it, re-plugged. Jumped in and started her up... heard a funny noise in the fan motor starting up... but it did start going and soon was blowing just fine!!!! So, drove 10 mins. to home, ate lunch. Came out and started the car and this time... no fan again.
I think maybe the fan was on its last whirl and is intermittently shot now... or for good. Any thoughts? Is it difficult to replace this fan?
 

·
Registered
Joined
·
23 Posts
Jumping into the middle of this thread, I'll just like to ask for opinions on what I hope is not the symptom of the same problem that Chris has encountered.
On Saturday, my acc con fan started to make a humming noise as if there was a trapped leaf or other item hitting the fan-blades. They noise rises in intensity as the fan speed increases. The acc con is fine and the fan is still blowing OK. There are no faults registering on the acc unit. I hope that this is just a bit of stuck debris as I can't afford a potentially costly fix at the moment. Anyone have any reassuring words (if its a blockage wil it clear or will I need to get the fan area cleared out)?
Many thanks

Silverfox
 

·
Registered
Joined
·
11,030 Posts
If its a leaf or twig they tend to break up and get expelled via the air vents. If you look either end of the panel where the wipers are under the bonnet you'll find two holes where debris tends to build up, just keep these clear to prevent anything else getting into the system.
 

·
Banned
Joined
·
61 Posts
Man, yesteday was not a good day for 9-5 cabin fans... the one in my SE crapped out as well. But I have been suspecting it for a while as it knocks down to some odd speed after starting the car and makes a whining/whirring noise. It worked after being shut down while driving for an hour, then we shut down the car, restarted after a few hours, it worked again then crapped out after 2 hours of light use. Odd.

Carl
99 9-5 SE


nickeldog said:
My fan stopped yesterday too. The display on the dash still is showing everything (auto, lo, etc...) but not blowing. Will the relay on 1999 9-5 4 cyl turbo be the same as the ones you describe? Is it in engine compartment too? If not that, is the fan that you show accessible and easy enough for me to replace?
 

·
Registered
Joined
·
22,211 Posts
Discussion Starter · #20 ·
Mine has currently mended itself :roll:
 
1 - 20 of 51 Posts
Top