SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello, greetings and saluations to all.

I took a 94 900S hatch (2.3L auto) for a spin last night, and I am pretty sure I will buy the thing. I do have a couple of questions for the SAAB experts around here though:

The info panel informed me of both a Front Light Failure and Brake Light Failure even when the lights were working perfectly. What could cause this? Is it a serious problem (I mean, you can easily clear the panel and ignore it, but is there something more serious underneath that I should be concerned with)? Is it much of a job to fix it?

Secondly, (and I fear this has been covered - if so a simple link to the answer will suffice) - on the info panel, there is a row of pixels that are not displaying. Is this tough to rectify?

Thanks for the help everyone. Much appreciated.

- Nils
 

·
Registered
Joined
·
3,286 Posts
Nils:


Normally, I would allow a moderator to move your post, but seeing the hour and since you probably want a quick answer, please post this question on the 9-3 and NG900 board.

We are the 'classic' 900 people -- 1979 - 1993. Our cars don't have pixels and the like.

I hope that you find the answer that you need there.
 

·
Registered
Joined
·
3,286 Posts
Jezzadee said:
I don't know, I reckon 20 minutes is pretty quick ;)
Yup, it is. I didn't see you on the board, you must have been messin' around the Lounge, etc. Thought that I would do him a favor. Can't imagine what buying a car in Japan must be like -- they've got rules for rules over there.
 

·
Registered
Joined
·
21,583 Posts
On the brake lights, I would closely examine that silly 3rd brake light and ensure that all is OK. Then change the real brake light with new bulbs.

One old bulb may may more resistance that the other; the overly sensitive computer measures this and is confused.

There are threads on the pixels - sometimes the board can be repaired- but it takes an expert or a quasi-expert..
 

·
Registered
Joined
·
2,584 Posts
First off, welcome to the forums. Here is a link for the SID pixel fix: http://www.users.waitrose.com/~randmwilliams/index.html it appears a little intimidating to perform. Earthworm is on the money with the bulb thing. The computer measures the resistance in the filaments in the lighting systems. So if your getting a 'Brake Light Failure' message on the SID, its picking something up, either a bulb that has been put in is of the wrong specifications, or a bulb in the 3rd brake light is bad, or you have a bulb that is going to fail soon (the resistance readings are that sensitive). The front light monitoring system works on the same premise, so if an innapropriate bulb is put in or is on it's last leg, the SID will throw the message at you.
So were you able to get someone to sit in the car and press the brake and check the brake lights (or vice versa)? I just noticed that the system will distinguish between a 'Brake Light Failure' and a 'Rear Light Failure'. So, since its only a matter of a few bulbs, I'd just replace all the brake lights and see what it says. Just make sure to have the correct spec. bulbs in there. :cheesy: . Good luck!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Thanks for the help guys. Sorry about the whole 'posting in the wrong forum' thing. All hail me, King of the Bumbling Newbies.

I'll have a play around with bulbs and see what happens, the dead pixels are really only cosmetic, but I might look into getting them sorted out at a later date.

I have decided to go ahead and buy the car (pending a mechanic running his weather eye over it) and I cannot bloody well wait!

Thanks again all.
 
1 - 7 of 7 Posts
Top