SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2,475 Posts
Discussion Starter #1 (Edited)
This is definitely a first for me.
Last night after work (just like every other night), I get to the Saabllennium Falcon (2005 9-5 Aero) and start it up.
The stereo (Denso NAV/Harman Kardon/Prestige AS3) is all static, I look down and think "Hmmm, that's weird, why is it set to a random non station?" Then I realize, ALL the presets have been wiped and are now back to factory defaults.
I checked AM, FM1, FM2 and even checked the HOME and AWAY settings. Yup, they're all reset. Then I check the actual sound settings (I use ATC 3 for FM and ATC 2 for AM) and that stayed intact.
Does anyone have any ideas what on earth could have caused this? I put some of the stations back and have driven the car since (multiple startups) and the stations I put back in presets are still there. I'm completely perplexed. Could it be that my Saabllennium Falcon just doesn't like my choice of radio stations anymore and wants to hear something different... Like the sound of it's own voice? Naaaawwwwww, it can't be that simple. So, back to my question, any ideas on what could have done this?
 

·
Registered
Joined
·
402 Posts
Hmmm... first the clock issue, which miraculously resolved itself, and now this. I guess the Denso NAV unit just loves to play tricks on us.

Sorry I can't be of more help, but I've experienced bizarre behavior from the factory NAV unit on my '07 throughout the car's lifetime.
 

·
Registered
Joined
·
2,475 Posts
Discussion Starter #4
1 - 4 of 4 Posts
Top