SaabCentral Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
i have a 2003 9-3 and the radio and the sid unit wont work and idk why or wat to do can anyone tell me how i can fix this
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
i have done some research and i have had it diagnostically checked and they said it the onstar modual its bad. i have tons of head units is it possible to put on in or were can i find a modual
 

·
Registered
Joined
·
12,509 Posts
Get the etadyne loopback connector to eliminate the Onstar, 03's have the analog Onstar system, no longer in use. So if the onstar unit is causing the headunit not to work, that should eliminate the problem. You can replace a head unit, but as I recall it must have been "Divorced" from it's previous car via Tech II, then re-assigned to the new vehicle. Hopefully someone will correct that if I'm remembering that wrong.

Here's an Onstar thread turned up by the infamous Search Forum function:
http://www.saabcentral.com/forums/showthread.php?t=117452&highlight=removing+onstar
 

·
Registered
Joined
·
1,559 Posts
head unit replacement can be done without divorcing as long as the donor car has all the same options. I replaced my ICM2 with one(not divorced) from a junk yard no problem at all. aside from that damn center vent!!! lol

Get the etadyne loopback connector to eliminate the Onstar, 03's have the analog Onstar system, no longer in use. So if the onstar unit is causing the headunit not to work, that should eliminate the problem. You can replace a head unit, but as I recall it must have been "Divorced" from it's previous car via Tech II, then re-assigned to the new vehicle. Hopefully someone will correct that if I'm remembering that wrong.

Here's an Onstar thread turned up by the infamous Search Forum function:
http://www.saabcentral.com/forums/showthread.php?t=117452&highlight=removing+onstar
 

·
Registered
Joined
·
383 Posts
This might sound pretty simple or even stupid to some, but the first thing I would check is the fuse box and make sure they are not burnt. It could be a simple fix.
 

·
Registered
Joined
·
12,509 Posts
Infotainment = fuse 14 in left side of dash

Onstar = fuse 19 Left rear fuse panel

two separate circuits
 
1 - 8 of 8 Posts
Top