SaabCentral Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1 (Edited)
Hey Saabers = just got my saab 93 (2003) back from the mechanic for a water pump change - fyi ..cost about $ 500 :roll:

I have now noticed a few things with my electrical since my baby is back ..:eek:

1- my ICM2 does not come on thus . no radio - i disconnected the battery , waited as another thread/discussion suggested , but no change..(is there a fuse I can check )Also noticed my NO ONSTAR light is blinking

2- my turn indicators does not make the click sound anymore , the blinkers come on but you dont here the clicking noise ?? (is there a fuse I can check )
3- my wipers work but when on low..they stop half way and continue ?? ..(is there a fuse I can check )



Troubles ..Yes ;oops:
Love it still ..like a bad habit ...:cheesy:

Your feedback is needed ...
 

·
Registered
Joined
·
73 Posts
Discussion Starter #2
ICM2 Radio - FUSE ??

isd1027 said:
Hey Saabers = just got my saab 93 (2003) back from the mechanic for a water pump change - fyi ..cost about $ 500 :roll:

I have now noticed a few things with my electrical since my baby is back ..:eek:

1- my ICM2 does not come on thus . no radio - i disconnected the battery , waited as another thread/discussion suggested , but no change..(is there a fuse I can check )Also noticed my NO ONSTAR light is blinking

2- my turn indicators does not make the click sound anymore , the blinkers come on but you dont here the clicking noise ?? (is there a fuse I can check )
3- my wipers work but when on low..they stop half way and continue ?? ..(is there a fuse I can check )



Troubles ..Yes ;oops:
Love it still ..like a bad habit ...:cheesy:

Your feedback is needed ...
Where is hte fuse for the Radio ?
 
1 - 2 of 2 Posts
Top