SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter #1 (Edited)
Rear hatch leak?? Ice inside windows

I've been having my windows fog up, mainly my hatch and rear side windows. Now that it's cold i had ice on the inside of my rear window tonight! I went out just now to look for a leak, and noticed the spare tire cover was wet. I pulled back the carpeting on the right side, gas tank side, and noticed what appears to be water lines going down into the spare tire well. None of the side carpeting is wet or damp so it looks like the water is coming in behind it and running down. I've read in other posts that the two biggest causes of leaks are blocked sunroof drains and leaky rear light assemblies.

This leak must have been going on for a while because a small panel under the carpeting is a little rusted.

Does anyone have pics or a thread where I can see how to fix these two things??
 

·
Registered
Joined
·
21,583 Posts
http://bellsouthpwp.net/m/a/mattiaso/WebPages/Auto/trunk_main.htm

This excellent pictorial/tutorial may help, courtesy of Mattias.

I seems as if your defrosters are on vacation as well.....
How long is your warm up ?? ; it should be no more than 4 to 6 minutes...
The electric defroster grid is repairable using a liquid solder designed for this purpose.
 

·
Registered
Joined
·
172 Posts
Discussion Starter #3
Thanks! I'm going to check that area out later on today. That is definately where the water seemed to be coming from when I looked yesterday.

My defroster is working, a few lines aren't. I did try that solder repair kit, but it didn't seem to work. I put multiple layers where it was scratched and it hasn't worked. One of the lines seems 100% intact and I can't seem to see any places where it could be scratched.

I'll look into that spot and report back. I know that there is a leak there, would that cause the windows to freeze on the inside??
 

·
Registered
Joined
·
172 Posts
Discussion Starter #4
OK, so i just went out and pulled the back corner carpeting. BINGO!! There was a clear water trail from the back corner. I pulled out the sunroof drain line and it seemed clean. But the rubber grommet that it goes into looks like it may have been the problem. The front half looked as if there were no silicone at all!! I gooped it up as well as the tailight housing. It looked like a small seem just below the tailight section had a minor leak so I gooped that up too!

I'll take another look to see if it's wet after the next time it rains.

Thanks for the diagrams and suggestions, hopefully this did the trick!!
 
1 - 4 of 4 Posts
Top