SaabCentral Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
This is on a 1997 900SE 2.0L Turbo. This is a very odd problem that only happens once every few weeks or months, and it really only happens about 5 miles after I top off my gas tank. What happens is everything runs perfectly fine until my RPM goes down to about 1.5, slowing down at a stoplight or what-not. When this happens the electrical dims, the RPM plummets and the vehicle stalls.

To start the car up again, I have to give it a good amount of gas while turning the key to start it or all that will happen is the starter will go, but the motor will not start. Then comes a very tough balancing act of clutch and gas when stopped or slowing down to keep the car from dying again, until I can hit the highway at which point it's fine, and then the problem disappears and isn't heard from again for another few weeks or months. This problem has been happening for almost the past two years, but I can't identify the source, especially since it's almost impossible to recreate the problem once it goes away.

Another thing that may or may not be related is once every about 6 weeks, the fuel gauge randomly drops to zero while driving, and then next time I start the car it's fine again.

I'm assuming it has to be something in the fuel delivery system, maybe the fuel pump or sensor? Could it be something is preventing the pumping of fuel on its own while idling?
 

·
Registered
Joined
·
21,583 Posts
1 - 3 of 3 Posts
Top