SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
260 Posts
Discussion Starter · #1 ·
i have a 89 900 trubo and i think the wastgate is on its last leg. it only boost ever once and a while and only last for a while then stops. also the adjustment rod is shortened all the way up and only base boost at 6psi which i want but shouldn't thier be some adjustment. i have checked all my vacume hoses and tried three or four apc boxs and apc valve. so if any one can help i need boost

stephen
 

·
Registered
Joined
·
5,975 Posts
wasted gate

Hello fellow notchback owner:cheesy: , have you tried removing the arm to the wastegate actuator and see'ing if you can move the wastegate, on the turbo i just put on my car the wastegate had seized up a bit, after a load of wd40 and wiggling it came back to life. If the wastegate is stuck open you'll not get good boost.

I've never done this so i don't know if it would work but you could try disconnecting the hose to the actuator (disconnect it from the solenoid) and pulgging it into a foot pump, then pump and see if the actuator arm moves, the diafram can split so it it does'nt move that could be the problem.

One note of warning, if you need to remove the actuator you'll need to take the oil return pipe off first as that sits in the way of one of the nuts, remember to put the actuator back on first, i made the mistake of putting the return pipe on first, and ofcourse then could'nt bolt one side of the actuator back on:roll: .
 
1 - 3 of 3 Posts
Top