SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2,539 Posts
Discussion Starter #1
ok...shortly after warranty expired (yep, something always happens after warranty), the hood mechanism is not closing properly. When I release the hood, the spring mechanism doesn't appear to revert back. The last time, I was able to push the level forward, but the last time I opened the hood, I had to manually pull the level forward form the hood.

Suggestions on a fix?

Paul
 

·
Registered
Joined
·
1,089 Posts
brunp said:
ok...shortly after warranty expired (yep, something always happens after warranty), the hood mechanism is not closing properly. When I release the hood, the spring mechanism doesn't appear to revert back. The last time, I was able to push the level forward, but the last time I opened the hood, I had to manually pull the level forward form the hood.

Suggestions on a fix?

Paul
Have you tried lubricating the mechanism?

Often though it's the cable that sticks - see this post:
http://www.saabcentral.com/forums/showpost.php?p=881961&postcount=5

Greasing the bonnet (hood) cable and latch mechanism is one of those preventative jobs I do every so often, as they can often sieze if left!
 

·
Registered
Joined
·
2,539 Posts
Discussion Starter #3
nope....I personally would not have even though of lubricating anything within the hood latch mechanism. I had a numerous cars in the past, older than the 9-3ss and nothing like this happened. I will give that a try, but will have to figure out how to get down there first..

Paul
 
1 - 3 of 3 Posts
Top