SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter #1
Well i searched alot of the threads and found some stuff i can look at. But i'd like an opinion cuz i would like my car on the road in the next two days. My car just started to idled at about 2000rpm and and drop down once in awhile but usually stays at 2000rpm. Now i have to stay on the throttle to keep th car running or it will stall out. While driving on the highway the CEL came on. Sometimes the CEL would turn off and when it turns off my knock sensor would light up for a second. Not long ago my distributor was getting oil in it and making the car stall but it was just cleaned out and a new cap was put on it so i dont think that is the problem.

Im thinking this could either be my o2 sensor or maybe just a vacuum leak. Or maybe some electrical problem since my sensor light is going off for no reason.
Any help would be awesome.
 

·
Registered
Joined
·
962 Posts
You might have 2 separate problems - high/low idle, and CEL/knock sensor light coming on. The two might not be connected.

As for high/low idle, clean out the AIC valve, which could be a sticky AIC. It's a 10-minute job. Just disconnect the wires and the 2 hose clamps and spray the inlet and outlet liberally with carb cleaner. No need to disassemble the valve mechanism if you don't have the right tool for that.

As for the CEL, I suggest you pull the code(s) out. If it's the O2 sensor, the code will tell you.

I'm afraid I can't help you on the knock sensor light tho.

James
 

·
Registered
Joined
·
326 Posts
Discussion Starter #4
Yes I installed a knock sensor light. but it just flashed when ever the CEL went out. So im not too worried about that.

Well ill try cleaning out the AIC and maybe pull my codes and see what I come up with.
 

·
Registered
Joined
·
326 Posts
Discussion Starter #5
Well before I did all that stuff. I checked some of the easier stuff for a problem and I found out that my BOV was staying open all the time so it was acting like a vacuum leak. So I tightened that up all the way and now my car runs just fine. It has more power and seems to spool up faster too.
 
1 - 5 of 5 Posts
Top