SaabCentral Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter · #1 ·
Hey guys. The 03 electrical gremlins are at it again. Regardless of the setting, i can't keep my high beams "on." when i pull the handle, they go on, but only as long as the lever is pulled back. Any thoughts? I can't drive around holding the handle all the time.

In other news........its finally snowing here in southern ct, looking forward to some fun in the car.:p
 

·
Registered
Joined
·
9 Posts
FYI - unless your SAAB is built differently than mine, you pull the lever to you to "flash" your high beams; you push the lever away from you to actually put them on.
 

·
Registered
Joined
·
3,092 Posts
Well this might sound stupid, but I have the same symtpoms as the ones you mentioned when I have the actualy light switch control to position 2.
 

·
Registered
Joined
·
159 Posts
jayarekay338 said:
Hey guys. The 03 electrical gremlins are at it again. Regardless of the setting, i can't keep my high beams "on." when i pull the handle, they go on, but only as long as the lever is pulled back. Any thoughts? I can't drive around holding the handle all the time.

In other news........its finally snowing here in southern ct, looking forward to some fun in the car.:p
the reason you might having this problem is because u probably keep your switch on the off position and forget to turn it to the on position. that is the only way you can keep your highbeams on all the time.
 

·
Registered
Joined
·
434 Posts
If the center panel for the hvac, etc. isn't lighting up after dark and your high beams won't stay on as you say, then the headlight switch on the left side of the dash needs turned on.
 

·
Registered
Joined
·
231 Posts
Discussion Starter · #7 ·
03Arc said:
the reason you might having this problem is because u probably keep your switch on the off position and forget to turn it to the on position. that is the only way you can keep your highbeams on all the time.
All three positions have this same problem, that is the first thing i tried. Perhaps it is the relay, will check tomorrow.
 

·
Registered
Joined
·
159 Posts
i was having the same problem with m car on all positions but i just kept pulling the lever back and back and back again until it just started working.

like a spanish saying. "a las buenas o a las malas" meaning either your going to work or your going to work lol good luck on yours
 

·
Registered
Joined
·
7 Posts
mrbrett said:
If the center panel for the hvac, etc. isn't lighting up after dark and your high beams won't stay on as you say, then the headlight switch on the left side of the dash needs turned on.
thank you SO much!
 

·
Registered
Joined
·
2,020 Posts
03Arc said:
the reason you might having this problem is because u probably keep your switch on the off position and forget to turn it to the on position. that is the only way you can keep your highbeams on all the time.
THANK YOU!!!
 
1 - 10 of 10 Posts
Top