SaabCentral Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have a 2004 9-3 Aero with great HID lights and I'd love to swap them to my 2007 9-3 daily but the 2007 female plug on the harness is missing a whole row of pins vs the Aero HID... I'm not super wiring savvy... is there any way to swap them?
 

·
Registered
Joined
·
8,835 Posts
Yes.
You need light switch, AHL box, sensors to rear and front axles and wirings.
You also need to reprogram UEC and lights to xenon.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Nice thanx! There is still the discrepancy in pin count on the connectors... Am I right in thinking that the second row of pins on the HID harness is only for the auto leveling?
If so I'm not really bothered about that feature. Is it possible to make those lights shine without it? Seems like it should be since you can install a conversion kit which would not have it...
Looking to just get the new car shooting HIDs out it's face by only swapping parts (and some Tech II work if necessary) from the fully functioning 2004 HID Aero to the 2007 non HID 9-3 is the crux of it... Possible to plug em in, tech II the computer to know that they're there and away I go with non leveling HIDs? Or is that wishful thinking?
 

·
Registered
Joined
·
8,835 Posts
Yes, second row is for leveling.
Yes, you miss auto leveling and you have to adjust height manually.
You need to reprogram UEC to xenon, otherwise you might have flickering lights and warning sign.
 

·
Super Moderator
Joined
·
9,061 Posts
thought the MY07 onwards are a different style of headlamp thus won't fit MY03-06..
 

·
Registered
Joined
·
8,835 Posts
My 03-07 have same headlights.
My 08-14 have same headlights.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
You say flickering and warning light might be a thing without the EUC reprogrammed for xenons...I know the lights are fine because they work on the aero no problem but I've plugged them in to the new car and just get no light at all out of the HID element (DRLs work, turn signals work). Could that be down to the EUC setup needs to be done also you think?
 
1 - 8 of 8 Posts
Top