SaabCentral Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi
could someone please give me some advise on my problem.
I have a saab 93 2003 vector. the otehr day the remote 4 button key stopped working, i thought it was strange to just stop and had to open passenger door with the blade. The car starts ok and there is a error message saying "replace battery". I replaced the battery but the key fob is still not working?
Any ideas on this please, do i have to sync it back up or anything?
Thanks
Ian
 

·
Registered
Joined
·
675 Posts
If there is nothing wrong with the icm it should re sycn itselt when you go to start the car again.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
I have another key which is quite damaged. The unlock button is missing, although this key does seem like its still works to lock or open boot
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Hi
I finally have found the fault - i think...
One of the metal tabs on the key was bent and not touching the battery, i fixed this and was working ok, although after an hour left the battery seemed to lose its memory again. I entered car through passenger door and started and key seemed to aline again and work fine since... so not sure if its temperamental fault or if its sorted now.
I feel i should also mention the carpets got wet last week when we had a big downpour and the drain tube was blocked. could this be an issue?
 

·
Registered
Joined
·
12,509 Posts
the amp under the seat might have gotten wet... but that wouldn't effect the key.... take it apart and just make sure everything is seated properly.....
 
1 - 8 of 8 Posts
Top