SaabCentral Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I have a 2003 saab 9-5. After driving my car for about 2-3 miles my engine will shut off like its not getting gas, and not start. Once the car sits for a couple hours it will start back up and do the same thing. I recently had the fuel pump, lines and filter replaced. I also bought a new battery and had the alternator checked. My car is well maintained and runs great when it is started! Please Help I'm out of ideas! a friend said it might be my Crankshaft Position Sensor?
 

·
Registered
Joined
·
2,339 Posts
I have a 2003 saab 9-5. After driving my car for about 2-3 miles my engine will shut off like its not getting gas, and not start. Once the car sits for a couple hours it will start back up and do the same thing. I recently had the fuel pump, lines and filter replaced. I also bought a new battery and had the alternator checked. My car is well maintained and runs great when it is started! Please Help I'm out of ideas! a friend said it might be my Crankshaft Position Sensor?
Sounds typical of a bad CPS.
 

·
Registered
Joined
·
869 Posts
Usually, not. When the CPS in my wife's car went it was even more dramatic (just didn't start again after shutting it off, luckily while she was home) and never a CEL light.
 

·
Registered
Joined
·
3,951 Posts
Four or Six cylinders? Auto or Manual Transmission?
 

·
Registered
Joined
·
8,299 Posts
I wish ALL posters would please say what the problem is in the title, all this "I need help" sh!t can be anyting and I really don;t like having to mouse over to read it, It and see I just ran my car into a pole, or its on fire or I got a 1 inch scratch,

Can we please be more descriptive in the post title??? Please...

Oh Yeah CPS...
 
1 - 14 of 14 Posts
Top