SaabCentral Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
alright folks, need some clarification here. I have purchased some audiobahn 4" and some 4x10s on ebay and they should be winging they're way over the atlantic as we speak (well...as I type....). My worry is that there isn't enough space to fit them! There has been much talk of 4x10 speakers in the rear, and some people seem to say the standard size is actually 6x4. I am beginning to think that perhaps the size of the aperture is different for different markets/years/models.... :roll:

Currently there is a 4" speaker in there in at one end of a rectangular hole but I (perhaps wrongly) assumed that even if the size of standard speakers fitted varied the area where the speakers are would be uniform in size across all models and markets...don't mind making mounts as long as there's space!

Please someone could post some pics of the rear speakers in their 900s to alay my fears (or make me cry)...help would be much appreciated..

cheers, mits
 

·
Registered
Joined
·
818 Posts
The stock rears in my car are 4" and there would be no room to fit anything larger I am afraid, however I have 6X9's on the rear pacel shelf as well as new kenwood 4" in the stock locations. Cant you just look and see if it looks possible to fit a 4X10?
 

·
Registered
Joined
·
569 Posts
Jezzadee said:
If they are too big just cut two holes in the parcel shelf and mount them there.

Anyway, here's a few results on the subject.

Welcome to Saab Central :cool:
haha way to go jezza... if you click on the link, the page comes up and says "sorry, no matches" :nono;
 

·
Registered
Joined
·
252 Posts
Thy shall not be worried DrKatz. :cool:
Check out some treads in the forum, the speaker item in the c900 is something many strugled with. :)

As far as I know:
front: 4"
Rear: 4 x 10

I have 5 x7 in the rear, which are (basically) too wide for the stock position. I made some wooden spacers, works perfect.

So, I think your 4 x 10 should fit rightaway.

Blacky
 

·
Registered
Joined
·
9,170 Posts
therealturbofan said:
haha way to go jezza... if you click on the link, the page comes up and says "sorry, no matches" :nono;
How very odd... I checked it before posting and it was working then. ;oops:

Anyway, to obtain identical results, type the words 'speaker size' into the search function here, and all will be revealed. Hopefully.
 

·
Registered
Joined
·
3,470 Posts
drkatz
I can confirm thru experience that the Audiobahn 4x10's DO fit the stock locations, as i have them fitted to my baby.....

Fitting IS a little fiddley, mainly due to not being able to get to all of the screws to bolt them up. As a result I only have 3 screws each side. However, I am simply gonna take them out, and replace the crappy screws with some M5 studding, and remount them.

Out of interest, are you getting the ones with detatchable tweeters? - they rock!

G
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Yeah both the 4s and 4x10s I'm getting have the detatchable tweeter...how do you find the sound? where do you have the tweeters mounted?

thanks for the replies from everyone by the way..

mits
 

·
Registered
Joined
·
3,470 Posts
drkatz,
Ive not actually mounted the tweeters yet, but only coz im gonna make some less "rattle-y" mounts in the stock locations - i do get a bit of buzz @ high volume - but the new mounts should cure this

Having said that, the sound is great as it is - audiobahn 4x10's in rear, 4" fronts with built in tweeters, AND some JVC tweeters in the stock, dash mount locations (i'll disconnect these when I put the others in the back..... two much top end)

Let us know how you get on
G
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
all is well

ok so I got my speakers today and they look like they'll fit fine although I'll prob have to drill 2 extra mounting holes for each speaker as I seem to be missing them on the side of the metal speaker cutout nearest the back of the car...panic over... for now...

now I've got my audiobahns, rockford amp and alpine underseat subwoofer...just waiting for the kenwood head unit off ebay that I paid for 2 weeks ago...bloody annoying, speakers came from US but head unit taking longer from oxford!

cheers for all the feedback anyway,
mits
 

·
Registered
Joined
·
13 Posts
Discussion Starter #13
not installed it yet as i'm waiting for the head unit so I can put everything in in one go...it's an Alpine SWD-1600 Under Seat Active Subwoofer, you can find it on this page http://www.hendoncarstereo.co.uk/trolleyed/12/index.htm near the bottom...I'm gonna put it under the drivers seat towards the back....can't put it at the front because of the seat adjustment bar...

I'm not looking for mirror shaking bass just want to reinforce the 4" audiobahns which are going in the front (they only go down to 90Hz). I'll give you a report when I get the head unit and install everything..

mits
 

·
Registered
Joined
·
3,470 Posts
drkatz

Remounted the 4x10's in the back, with the tweeters mounted within the drive units.... and they sound BOSS!

As far as mounting goes, I suggest that you romve the carpet trim from over the speaker locations (simply pop out the black platic fastners and unkook from the headliner) This will allow you to drop some short M5 bolts down thru the stock holes (open them out a bit) and do them up from underneath - voila, no buzz @ volume

Let us know how you progress (esp with the amp, as i'm thinking of maybe powering the 4x10's)
G
 

·
Registered
Joined
·
13 Posts
Discussion Starter #15
update!

right, well I finally received my kenwood head unit last week and, after recovering from flu, have installed amp, new speakers (audiobahn 4x10 rear, 4" front) and said head unit....decided to ditch the underseat subwoofer and go for a focal 13ks mini sub in the centre console...will be fitting tomorrow so I'll post some pics over the weekend...just got to figure out where I'm gonna put the tweeters in the front...
 
1 - 15 of 15 Posts
Top