SaabCentral Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
So i have the dreaded random misfire on my 04 saab 9-3 Linear.
I've read alot. And done alot but seems it keeps doing the same thing i have changed the coils to oem coils i changed the spark plugs to the oem. Ive read the car does not like anything else but oem stuff. Ive changed the turbo mine had a a crack in the compressor side and it was whining like a supercharger.
But the misfire. Keep not going away and I dont know what else to do to fix this car ive put alot of new parts. And the junk yard only gives me 400 for it. I have a tech 2 but it does not seem to find out what it has. Bad
Any Info would be good.
 

·
Registered
Joined
·
2,945 Posts
Read stored faults and provide a photo, provide more info on the misfire, is it when cold/hot both, idle idle/D drive .. etc
 

·
Super Moderator
Joined
·
20,194 Posts
So, what are the codes?
 

·
Super Moderator
Joined
·
20,194 Posts
He replaced the coils.

Use your tech2 to clear misfire counts. Star car and let it idle for 5 mins or so and then pull up misfire counter and let us know what they are for all 4 cylinders.

Also check vacuum hoses by oil filter housing (the one with the check valve on it) and by the oil dipstick (the T).

Was there oil in the spark plug holes when you did coils/plugs?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
I Checked all that. Spark plug. Number 3. tip was gone. Thats when i went and replaced
all coils and spark plugs not cheap. But i was hoping it would. Do the trick. So after that i replaced the turbo
269872


269871
 

·
Super Moderator
Joined
·
20,194 Posts
That tip and strap flying around in there could definitely do some damage to valves or piston. Let's see what the tech2 says are the grumpy cylinders.
 

·
Registered
Joined
·
2,945 Posts
So the only codes is P0300 !
And it only misfire when u demand boost and not on idle !
No oil currently on any spark plug hole ?

clear the misfire counters as diggs suggested, let it idle for 5 min and provide a screen shot for the four counters, and then clear them again, take it for a spin and make drive the car the way it misfire usually and provide another screen shot for the counters
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12
Thanks guys for trying to help this one is going to the scrap now the cim wont communicate with the ecm. So im just done with it. It was a great car but has to much problems. Thanks again
 

·
Registered
Joined
·
8 Posts
Discussion Starter #15
When i tried to diagnose the engine controls i get a message that the CIM cant communicate with the ecm. To check pin 1 and 4. To flash the high beams if no high beams then there is no i-bus the high beams work rhe car starts but cant drive it because it starts misfiring
 

·
Registered
Joined
·
8 Posts
Discussion Starter #17
I have checked the car per video and the car starts like ive said it before heres some picture of the misfire counts. I had to ise the icarsoft because the tech2 does not let me enter as you can see
269905
269906
269907
 

·
Registered
Joined
·
2,945 Posts
the video above demonstrates how to diagnose the CIM and the wiring between CIM & OBD socket, its recommended u do that before u assume bad CIM, forget about the fact that the car in the video did not start.

Looks like number 1&4have the most misfires, swab coils 1&4 for coils 2&3 and reclear the misfire counters and re-read them as indicated above once at idle and once after a drive
 
1 - 18 of 18 Posts
Top