SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Help iv got problems with my 2.2tit 03 model, any ideas for a common fault that could be causing the following symptoms, about a week ago the sid showed abs fault followed by traction control fault i took the car to saab who relieved me of £70 gbp to put the car on the tech 2 and it showed low voltage fault but doesnt say where exactly, they say they will need it for a full day at a cost of £70 per hour to trace the low voltage fault........sounds like an open cheque for them, anyway today the car sid came up with brake failure stop immediately ! the brakes still feel ok and the abs still works. Any ideas on what could be the problem before i pay the saab stealer a fortune !

cheers hopefully
sie
 

·
Registered
Joined
·
381 Posts
I have read posts on here as well as other Forums suggesting if the battery is on it's way out you can get all sorts of strange SID warnings.

Not finding a specific fault, SID warnings on a number of different systems all point to the battery being at fault.

The clincher is the Low voltage code!!

On that basis, I would get a new battery and fit myself before paying out for specalist disagnosis!
 

·
Registered
Joined
·
1,089 Posts
Agree 100% with chr15gb:cheesy:. It sounds like the battery.

You could try checking it with a voltmeter - anything below 12.4 volts standing (i.e. without the engine running) seems to cause problems on these cars.
 

·
Registered
Joined
·
1,347 Posts
I echo the battery issue. When the battery went low in my c900, the ABS light came on, and when I fired up my 86 9000T after it sat for several months, the "SID" (known as the Electronic Display Unit to us 9k'ers) went bonkers on me, only when I bought a brand new battery did the issue clear.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #6 · (Edited)
ok iv checke dthe battery with a multi meter it is showing 12.7 volts but only 350amp which should be 700+ does this mean the abttery is shot ????? there is no probs starting the car
 
1 - 6 of 6 Posts
Top