SaabCentral Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
hi all i have a 93 1.8t on a 03 plate the car has a small leak oil so i took the air box off and give the engine a good jet wash around alternator area and engine etc, i had the maf discontected i then started the car up and moved it about 80 mteters it was in limp mode to dry off to see if i could locate the said leak however when i looked on the instument pannel the engine check light has come on on the clocks not sure if it was because car was started with the maf off or not. the question is can it be reset to remove the light or does it need to be done at a garage thanks in advance....chris
 

·
Registered
Joined
·
12,509 Posts
If you've gotten your MAF repositioned and have checked around your plugs for water. See if a few cold start cycles will clear the CEL, if not, Disconnect your battery (Negative) for about ten minutes. If that doesn't clear it, it's shop time.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
JonV said:
If you've gotten your MAF repositioned and have checked around your plugs for water. See if a few cold start cycles will clear the CEL, if not, Disconnect your battery (Negative) for about ten minutes. If that doesn't clear it, it's shop time.
hi thanks i took the ecu plug off for 15 mins connected it back and started her twice and it went away now all sorted, just try to find the leak? but it had about 1.5ltrs too much oil in sad really with full saab history so will see if it was just it being too full.
 
1 - 3 of 3 Posts
Top