SaabCentral Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
I have a 1999 95 3.0 V6. it started juddering at 70 mph and losing power. Then CEL came on .I have pulled the relevant fuse, disconnected battery and reset throttle body etc and CEL goes out, but the problem has got worse. It now kanagaroos when going at low speeds particularly up hill.Recently it went in to limp home mode( electronically and mechanically) and the problem at high speed disappeared although there was reduced power. Any idea what is going on?
 

·
Registered
Joined
·
22,211 Posts
What was the outcome of this?

ecopower1970 said:
I have a 1999 Saab 95 V6. It has full dealer history and has had no problems. Recently it started holding back slightly at high speed as if it was missing slightly. Then one day i lost most of the power, got CHECK ENGINE, and had a little smoke/steam from behind the main block( rear). Took it to be looked at and they cant find out what the problem is. Not plugs, coils,air flow meter etc any ideas please
 

·
Registered
Joined
·
5,000 Posts
What OBD code was reported that caused the CEL? Will help a lot in troubleshooting. How long since the throttle body was cleaned?
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #5 ·
hi, thanks for the reply. Not sure which code, i will get back to you. The throttle body was cleaned 80,000 miles ago! Do they need regular cleaning and is it expensive?
 

·
Registered
Joined
·
5,000 Posts
The throttle body should be cleaned internally every few years to remove deposits that can interfere with operation. Takes a can of throttle body cleaner and an old toothbrush and about 15 minutes work in the driveway.
 

·
Registered
Joined
·
22,211 Posts
If this is continually happening as the previous posts suggests it sounds like you need a new throttle body :confused:
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #8 ·
Thanks, its going to Saab on wednesday so they will do it. Wthout knowing the code, what would you think are the other most likely causes?
 

·
Registered
Joined
·
1,793 Posts
Throttle body issue: My experience

I have a V6 that had throttle body issues. Here is my experience.

Bought the 2001 wagon, and with in 10 miles of driving off the lot the CEL and limp home mode went on.

3 trips to the dealer later the issue kept happening (they supposedly cleaned the throttle body each time, no luck).

With the help of Swedecar on the other Saab site, I brought a list of recommendations to them.

The thing that fixed it in the end was an update to the software (I think it was the ECU?) which allowed a wider voltage range on the throttle bodies.

Turns out that up until 2002-3 Model year, the throttle bodies had a fairly narrow allowable voltage range and a common issue was overvolting of the throttle body, especially after they get older and started getting deposits on them.

So, have the dealership check to see if you have the latest software with the wider voltage range. If you do and still have the problems, then you probably do need a new throttle body.
 

·
Registered
Joined
·
22,211 Posts
95Saab07 said:
Will there be need to reset any codes if the trottle body is cleaned as compared to replacing.
Cleaning the TB wont reset any existing fault codes :nono;
 
1 - 12 of 12 Posts
Top