SaabCentral Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi guys, firstly i'd like to say this forum is fantastic and i have managed to solve a few issues on my car with out having to post!!

I have recently accuired a Saab 900 SE 2.5 V6 courtesy of my father who loves saabs, he has had one ever since i can remember!!! I was driving a rover 600 si, the clutch and radiator went and my dad bought a brand new 9-5, and said i could have his 900, which was kind of him!!

The car is fantastic, great accelaration, very comfortable and im getting used to the fact it is a auto..

I have a minor issue (well i hope it is!!) which im sure somebody on the forum should be able to help me with..

I have no heating in the cabin, and bearing in mind it is only going to get colder i need it sorted and fast!!!

When i say no heating, there is no air coming out of all vents except the one next to the windscreen and the drivers TOP vent(The one aimed at the window) and the same with the passenger side (Again the one aimed at the window)... Does this indicate a blockage??? there is very very little heat and it takes forever, also i noticed that when driving if i turn off the heating for 5 mins and then turn it back on there is a short burst of more heat and then it goes back to cold shortly afterwards.. Can anyone help before i turn into Jack Frost driving my car!! I know how expensive it can be repairing a saab and i just wondered whether i could repair it without having to take it to daylight robbers, i mean the saab dealers.
 

·
Registered
Joined
·
21,583 Posts

·
Registered
Joined
·
138 Posts
I've got to agree with Earthworm, does the car have the more advanced ACC unit or the standard heater controls (two dials for heat and vent position).#

Did your dad have any problems or is this a new fault?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
hi guys, thanks for swift replys, i have the standard a/c controls a round dial with vent positions and another for the level of heat
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Well when my dad had the car he never used the heating as it was summer and he would usually drive it during the day, just got back from a quick shopping trip and guess what.. the de-mister doesn't seem to work!!!! Hopefully i should be able to sort that with a new fuse!!

With regards to the heating, there is no air what so ever coming out of any of the other vents, which include the ones under the seat, on top of rear ashtray, centre dash and alll the other ones, does that indicate a block somewhere??? I have very little knowledge of the heating systems in these cars and i havent seen a problem like it before..
 

·
Registered
Joined
·
138 Posts
Thats good if nothing else its easier to fix and possibly cheaper!

When you turn the heater control do you feel any resistance or does it spin freely?
Sounds to me as if the dreaded white plastic connector has popped, someone will no doubt post a link to help you fix it...
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
i just tried it, im guessing that u mean does it click when i change the position of the vent dial???


There is no resistance it just clicks, im guessing i need to open the driver side speaker ontop of the dash??

But what about the actual heat?? has the heating failed??
 

·
Registered
Joined
·
611 Posts
whats the temp guage doing. Is it reaching half way after about 5-10 minutes of the car being started?

If not, it could be a fault t-stat not giving you any heat
 

·
Registered
Joined
·
138 Posts
I've just had a look at the owners manual to have a look at the controls, when you turn the switch in the middle of the unit to adust the fan speed can you hear the fan getting louder as it gets up to no.4? This will let you know that the fan is getting power.

The air for the heater gets pulled in just under the windscreen, it then passes through a filter, i've never heard of one being blocked, anybody got any ideas?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
The fan does get louder, but it is cold air!!


I think i need to take the vent position dial aprt or something as there is no resistance so something must be broke!! Just tryed changing the fuse for the demister and that didn't wok so now im freezing cold in the car and i cant see out of the back window!! it gets better:D
 
1 - 11 of 11 Posts
Top