SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
Hey Folks,

I've done some searching and can't find anything that looks exactly like what I'm experiencing. Perhaps someone can help me pinpoint what might be going on under the hood of my 2008 9-3.

Problem is, when I push down on the gas pedal and my air conditioning is running, I can hear a moaning or straining sound from what I am assuming is the AC. The minute I turn the AC off, everything sounds just fine. Any idea what might be going on? Am I providing enough information?

I have owned the car since 2010 and had the full pre-owned certified warranty until things went downhill. But now things get me worried.. Thanks in advance!

MontanaVista
 

·
Registered
Joined
·
2,225 Posts
Strange!

Couple of things, when you mean AC do you mean actually pressing the AC button causes this or do you mean turning on the fan? AC compressor will put more strain on an engine when it is running but in modern cars, the compressors are very efficient. You may have a problem with your compressor under load. Could be compressor pulley bearing or the fanbelt slipping.

Can you replicate the noise when you stopped and you just rev the engine?Get someone to replicate what you are doing while you have the hood open listening to see if you can isolate where the noise is coming from.

Does your car have an ECU tune? You could be just confusing louder turbo noises from under your hood whixh have a more direct route into cabin with fan aperture open. Bit of a long shot that one.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #3 ·
Nijee, thanks for the response! An update to the situation, I had a scheduled oil change done at the dealer this morning and the sound is gone, for now.

It was happening when the A/C button was active, and the A/C comes on automatically on my model. Haven't figured out how to change that yet in the settings. The sound was still present when I had just the fan on, but it wasn't as loud.

I was able to replicate it, it was more of a groan now that I think of it. A friend and I took a look under the hood earlier today and the belt is in great condition, the A/C line was ice cold after just a couple of minutes of running the A/C. The compressor and everything else sounded normal when we had the hood open, even when we set the A/C to Max and applied gas..

It's an odd problem, would the water pump have an influence on this?

MontanaVista
 

·
Registered
Joined
·
485 Posts
Same issue on my 2007 aero. When the A/C is activated(only when I first start the car) there seems to be a noticeable groaning noise from the system. It's definitely rotational, because it get's louder and faster if I rev the engine or drive. But if I turn off the A/C, the noise stops. My guess is the A/C compressor assembly. Unfortunately, it would seem that it's one piece, and it's $500. Could be worse though, the one for my car is $1000.
 
1 - 4 of 4 Posts
Top