SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter · #1 ·
I've been lacking in my posts here recently, but was wondering if anyone had some thoughts on the issues I've been having. It's a 2002 Saab 9-3 with 250,000kms. Runs great except, recently its been doing the following:

1. When cruising on the hwy it will occasionally feel like its missing/hesitating
2. Rough when idling at times, worse with AC on

I changed the plugs last summer, and also the CPS. I didn't see any breaks in any vacuam lines either. Maybe a throttle body issue? It's never been cleaned
 

·
Registered
Joined
·
2,155 Posts
It could be the DIC on its way out. On my car the I was getting a random misfire code when driving on the highway and my idle was a little rough. Since I replaced my DIC the misfire code hasn't come back and the idle is smoother.
 

·
Registered
Joined
·
144 Posts
Discussion Starter · #3 ·
Would this cause a CEL to come on, as nothing is happening there?

I've owned the car for 5 years and have put on 135,000kms, but have also never changed the DIC?
 

·
Registered
Joined
·
2,155 Posts
I don't think it will always throw a code when it starts to fail. Do you have records of when the DIC was last replaced? I would buy a new or used one and see if it solves the problem, if it doesn't well it's a good idea to have a backup DIC for when it does fail.
 

·
Registered
Joined
·
144 Posts
Discussion Starter · #5 ·
The previous owner had no records of when the DIC was replaced, but I can tell it has been replaced as the date code on the new DIC is newer than 2002.

I guess it will just be trial and error. Will try a DIC and also a throttle body clean to see if that helps for starters
 

·
Registered
Joined
·
14 Posts
Hi all, I know this is an old page, but I have a 99 9-3 5 speed. For some reason, when I get off the high way, my idle has hesitation and backfire. Feels like it's going to stall out, but doesn't. Revs just fine, no loss of power. CEL is on, but for a small evac leak only, which 3 mechanics have told me has nothing to do with it. Starts fine, and backfire seems random/after highway exiting. I ordered a CPS in hopes that replacing may help, but all the mechanics are at a loss. Any ideas where to start? Has about 175,000 miles on it. Any help is greatly appreciated! I am new to Saabs.
 
1 - 6 of 6 Posts
Top