SaabCentral Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
Alright, here's the situation. I went to start my car and didn't hold the key on "Start" quite long enough. Okay -- no big deal right? I turned the key back to off and went to start again and got 2 distinct "clicks" and then nothing. So I took the key out of the ignition and put it back in and noticed the immobilizer lock didn't un-click as it usually does. Okay so I went as far as disconnecting the negative terminal on my battery for a few minutes. I reconnected it and still ran into the same problem.

Any thoughts on what it could be? I was going to try and jump it to see if that works, but other than that I'm out of ideas...
 

·
Registered
Joined
·
85 Posts
looks like battery is dead. Try a jump. doesn't have enough juice to move the starter and lock the steering.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #3 ·
looks like battery is dead. Try a jump. doesn't have enough juice to move the starter and lock the steering.
Strange. That's what I was thinking. I'll give that a go in the morning. If the jump works I'll just head on up and buy a new battery.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #4 ·
Jump started it this morning without a problem. Drove it around for 5-10 minutes and all appears to be back to normal. I think I'm going to get a new battery anyways.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #5 ·
Update, went and got my battery tested. Bad battery, but it lasted for about 6 years so I can't complain. I got a new one and put it in and all is well again.
 
1 - 5 of 5 Posts
Top