SaabCentral Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
My 2001 Saab 9-3 was having battery issues. I spent 2-3 weeks having to jump start it every time I used it.
The oil light had also been flashing on and off intermittently – and I was going to get an oil change soon.
Then, the last time I drove it, I had hit the 'W' (Winter) button, as it had been snowing. I then messed up with the jump start, connecting the red cable to the black and vice versa. There was a spark - but that's all. Hopefully, I had done no damage? I then jump started it normally - and got it going just fine....but it seemed now that every single warning light on the dash was on - all of them!
But - the car drove - and I drove it around the block, although it seemed to be a little sluggish - it felt as if the 'W' button was still engaged, but it wasn't displaying that it was still on - nor could I turn it on or off by pressing the 'W' button. Every warning light was still on as I drove it, too. But brakes seemed fine, steering fine.
I parked the car - and then yesterday got a brand new battery - at last! The car then started perfectly, first time - so that was good. But - still - every single warning light is showing. I have driven the car a few yards - and it still feels as if the 'W' button is engaged - although it is not displaying that it is on. Also - when I press the 'W' button nothing happens - it neither goes on or off - but it really feels as if the 'W' button is somehow permanently engaged. Pressing the 'TCS' button also does nothing - the panel shows that 'TCS off' - but I can't alter this either.
Any ideas? To me, it just seems that maybe the car is 'stuck' in 'W' mode and can't/won't reset. But why are ALL the warning symbols displaying? Surely all these things can't be faulty? Did my bad charge short circuit something? Is there an oil problem? Engine problem? Blown fuse? Any ideas??!!
Should I even be driving it at all?
Help!
Any d-i-y tips would be very gratefully received! I need a quick, cheap fix – just to keep the car going a little longer!
 

·
Registered
Joined
·
1,687 Posts
My 2001 Saab 9-3 was having battery issues. I spent 2-3 weeks having to jump start it every time I used it.
The oil light had also been flashing on and off intermittently – and I was going to get an oil change soon.
Then, the last time I drove it, I had hit the 'W' (Winter) button, as it had been snowing. I then messed up with the jump start, connecting the red cable to the black and vice versa. There was a spark - but that's all. Hopefully, I had done no damage? I then jump started it normally - and got it going just fine....but it seemed now that every single warning light on the dash was on - all of them!
But - the car drove - and I drove it around the block, although it seemed to be a little sluggish - it felt as if the 'W' button was still engaged, but it wasn't displaying that it was still on - nor could I turn it on or off by pressing the 'W' button. Every warning light was still on as I drove it, too. But brakes seemed fine, steering fine.
I parked the car - and then yesterday got a brand new battery - at last! The car then started perfectly, first time - so that was good. But - still - every single warning light is showing. I have driven the car a few yards - and it still feels as if the 'W' button is engaged - although it is not displaying that it is on. Also - when I press the 'W' button nothing happens - it neither goes on or off - but it really feels as if the 'W' button is somehow permanently engaged. Pressing the 'TCS' button also does nothing - the panel shows that 'TCS off' - but I can't alter this either.
Any ideas? To me, it just seems that maybe the car is 'stuck' in 'W' mode and can't/won't reset. But why are ALL the warning symbols displaying? Surely all these things can't be faulty? Did my bad charge short circuit something? Is there an oil problem? Engine problem? Blown fuse? Any ideas??!!
Should I even be driving it at all?
Help!
Any d-i-y tips would be very gratefully received! I need a quick, cheap fix – just to keep the car going a little longer!
Wrong Forum. Move it over to the 9-3 Forum. This is the SS for 03+. They should be able to give you an answer in there.
 
1 - 2 of 2 Posts
Top