SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys Im in a pickle here . I have a 99 900 turbo auto. The check gear box light came on about a month ago and the car went in to limp mode. I followed the procedure of cleaning the inside of the switch. This did not fix the problem. Since then I have obtained two NSS from the junkyard. Neither of these fixed the problem. There is no way all three of these switches are bad. It must be something small but what??? tried disconnecting battery and gearbox light with my pocket scanner but the light comes back on and the car goes back in to limp mode. I am seriously hurting for transportation right now. Any suggestions are welcome. Thanks
 

·
Registered
Joined
·
21,583 Posts
Do the full electrical service(alternator, grounds, battery)
We need 12 volts, 11 will not do.
Check - change the ATF.
Nothing like a fluid level that is too low(or high), or fluid that is filthy.
And there may be some other electrics on the auto-trans that need to be cleaned..
I should have a good repair manual.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Do the full electrical service(alternator, grounds, battery)
We need 12 volts, 11 will not do.
Check - change the ATF.
Nothing like a fluid level that is too low(or high), or fluid that is filthy.
And there may be some other electrics on the auto-trans that need to be cleaned..
I should have a good repair manual.

10 4 thanks earthworm. Already changed fluid. Is there any process of resetting or relearning the computer or anything like that you know of. Do you think the dealership be able to reset this "limp mode" any more then my pocket scanner? It was running fine before the check gearbox came out of no where.
 

·
Registered
Joined
·
497 Posts
Tricky one, maybe disconnect the battery for at least 15mins to 'reset' the system & see what happens.

Good luck M.
 

·
Registered
Joined
·
21,583 Posts
You probably need to employ the services of the Tech2.
Volts ?
This happened years ago with my daughter's Saab(check gearbox), I THINK:confused: a new battery fixed it.
 

·
Registered
Joined
·
276 Posts
Have you pulled the codes? You may have a speed sensor issue. You really need to read the code and get a solid diagnosis. Otherwise, we are just guessing.
 
1 - 6 of 6 Posts
Top