SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I bought a 91 saab 900 in June. Since then It's been living in the shop.

Problem-

Runs perfect.. then while driving, the engine will fail. After 20-60 mins the car will restart (like nothing happened) and drive a little more and then fail again. After 10-60 mins the car will restart and drive then fail. Never going very far after the first fail.
Sometimes weeks can go by w/o any problems. My garage is no help since they need it to fail to test, (of course it won't fail for them.) I have changed the fuel pump and ignition coil and the garage has replaced a few parts but the orginial problem is still occuring, besides the fact i have invested $2,000 in parts and labor. Any suggestions, or simialir problems out there? I am determined to fix this problem.

Reading other articles, I think maybe a Hall sensor? Can anyone tell me more about that?

Thanks
 

·
Registered
Joined
·
18,382 Posts
crank sensor...
 

·
Registered
Joined
·
2,313 Posts
As 900t suggests, your hall sensor is a crank sensor, buried away at the front (which is actually rear) of the engine. If it hasn't been looked at, then it certainly could be the culprit. Does your garage know much about SAABs? these cars really need someone who knows what they are doing and it sounds like your guy doesn't.
 

·
Registered
Joined
·
261 Posts
I would also vote on the crank sensor.....I had the same problem a couple of years ago....to my knowledge, the ECU is not a regular culprit, like it MAY be on a 1989.......


allen
92 'vert 900s
LIFE IS SHORT,EAT DESSERT FIRST
 
1 - 7 of 7 Posts
Top