SaabCentral Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hello, I'm stuck! I put in the key, lights come on and engine check completes but when i turn the key I hear a click and a low hummm but nothing happens. Lights dim, sometimes I get a traction control failure and/or steering lock failure when i then remove the key.
I've replaced the battery with a new one, checked the cables as much as i could see. The fuses look ok but to be honest I'm not sure what I would see if one was bad. I am hopping it's not the starter motor or alternator, how can I be sure which, can't afford any expensive fixes here.
 

·
Registered
Joined
·
8,828 Posts
Check battery voltage and charge.
Recharge battery.

Report back.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Bought battery yesterday, can't check the voltage, don't have the tools but the shop assured me it was fully charged and ready to go. Made no difference
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
I shorted the starter relay and i got some clicks from what sounded like from the shut off valve but nothing from the starter but bare in mind i'm doing this in a field, it's raining so the sound could have come from the starter.
 

·
Registered
Joined
·
8,828 Posts
Recharge battery.
What is your battery voltage?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #10
Battery voltage 12.8 after recharge, tried it a few times after starter replaced/ecu connectors cleaned/ISM removed and cleaned/Map sensor replaced. Voltage dropped to 11.6 have it charged back to 12.7 now.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Oh and after all that I have a p0100 fault indication. I've swapped out the mass air sensor a few months back but will put in the old one today to see if that fault disappears but that shouldn't stop the car from cranking should it?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #12
Further investigation, my crank shaft will turn only about 180 degrees in either direction before jamming......it appears I am screwed unless anyone has an idea
 

·
Registered
Joined
·
8,828 Posts
Battery voltage 12.8 after recharge, tried it a few times after starter replaced/ecu connectors cleaned/ISM removed and cleaned/Map sensor replaced. Voltage dropped to 11.6 have it charged back to 12.7 now.
Bad battery.
 
1 - 13 of 13 Posts
Top