SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Good morning all,

I have just joined the forum so hello to you all. Due to a Friday night purchase on ebay I now have 2 Saabs so I guess I am a bit of a fan... the 900 I bought has faults which I knew about but unfortunately the 9000 has just developed a fault which I would like some help on if possible?

Basically, on full accelaration the car goes up to full boost OK but when it gets there, it sort of 'flutters' - it looses a bit of boost and then it comes back again. It isnt violent, and at the moment it is intermittent but it is getting worse. The car is a 96 CDE FPT manual (quite rare I would imagine)

Any information or advice you might have would be greatly appreciated...

Thanks
Anthony.
 

·
Registered
Joined
·
18 Posts
I've had the exact same problem with mine. First I suspected a faulty APC Solenoid (all the hoses being OK) so I bought a new one and it made the things better... but didn't solve the problem completely. Turned out it was the DI-cassette that was dying and couldn't deliver enough juice at high-boost. Try fitting a working DI on your engine, if you can get your hands on one, and see if it fixes your problem.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
Thanks for that - I believe the DI was changed for a new one less than 2 years ago, so I may start with the APC solenoid first. Is this a service item from SAAB or is it a 'breakers' item?

Cheers,
Anthony
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #5 ·
the plot thickens

In addition to the above problems, when I come off throttle (after being on full boost), in addition of just the normal quiet whoosh from the DV, I am getting a fluttering sound and also what can only be described as a ghostly sound... v strange. Whilst the fluttering sounds very 'rally car cool', I suspect that it isnt particularly good news. Does this still point to the APC solenoid?

Thanks,
Anthony
 

·
Registered
Joined
·
98 Posts
Sounds to me like the fluctuation in boost is quite usual in fpt 9000's.
I have a 93' 9000 Aero and mine does the same exact thing.
Don't exactly know the problem, but it maybe a weak wastegate spring.
I had the same "sneeze" happen to me yesterday.
But I was only getting base boost because a hose was broken.
...Weird 9000 problems...
 
1 - 6 of 6 Posts
Top