SaabCentral Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello. I am a total newbie and looking for help!
So I purchased a 1989 Saab900 convertible a year ago. There are many things wrong with it, so I'm trying to work my way through the various issues. I am still enjoying the car though. Turbo boost comes on late and so strangely fast! . Yesterday I got a thumbs up by a 9-3 convertible and I was so happy!

All of the air distribution, AC switches are not working or working in some strange way....
Anyway, I pulled the instrument panel today. When I pulled it, I must have messed with the wiring that's already been hacked before. It seems that I've managed to pull off/out two wires from somewhere - I think from the headlight switch connector, as the headlight no longer work.

I looked for a photo of the wiring that goes into the headlight switch but I could not find it anywhere. I have the Saab 900 manual by Bentley but nothing in there.

Could someone help me with the wires (with color?) that should be going into the headlight switch?? I noticed that if I connect the yellow wire to the very short metal that's sticking out (but does not connect to the receiving connector) then my headlight turns on.... I don't think I broke that one so I'd hate to solder it on there.

Any help (with photos?) would be really appreciated!

Hopefully I can get to the next step of non working tachometer after this...
 

·
Registered
Joined
·
3,341 Posts
Welcome to the pleaures of the classic 900 ...... You need to be in the C900 workshop forum . This forum is for the NG (new generation ) 900 and the 9-3 , not the classic 900 .

This thread from the c900 Forum may assist .
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Wow thank you. I didn't realize I was in the wrong forum. the Link you gave me also might be helpful too. I will repose on the correct forum. !
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Welcome to the pleaures of the classic 900 ...... You need to be in the C900 workshop forum . This forum is for the NG (new generation ) 900 and the 9-3 , not the classic 900 .

This thread from the c900 Forum may assist .
I tried right away although it was dark out side already. Got the headlight working! thank you :)
Now the
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
hmm ok. I guess I have to take the instrument cluster out? I guess may be I pulled some wires off accidentally when I took it off before...
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
I did have the wire in and played around with it a little and now working! Thank you! oddly there are two dimmer switches not sure what each do but dint want to fiddle with it and cause damage! Now the speedo and clock need fixing!
 
1 - 10 of 10 Posts
Top