SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
I recently had a problem crop up with my car.

Car:

1997 900S
~125,000 miles
5-speed
Recently replaced the "Mass Airflow Sensor (?)" at the dealer along with new spark plugs, and vacuum hoses. The fuel filter has also been recently replaced (in the process of diagnosing the Mass Airflow Sensor issue).

The problem is this, when I try to start my car after work, the car is hard to start/get it to stay running. Usually what happens is that the car starts, but when it trys to find idle, it dies. Sometimes it won't even start. Usually I have to make 6-8 attempts then it will start and stay running, although it will be fickle for a minute or two, ie if I try to rev the engine too soon, it will die again. The weird thing is that this only seems to occur when it's cold and dark. When I go to start it in the morning for work (8:00 am), even if it is just as cold as at night, it starts the first time every time. This problem only started recently when it got cold up here in PA. I've had the car for only 9 months, so I have never driven it in the late fall/winter, so I don't know if this was an issue with the car before.
 

·
Registered
Joined
·
21,583 Posts
Welcome to SaabCentral ,Slickninja

IMO, the first item to check is the ECU coolant temperature sensor, the one on the inlet manifold.
As usual do the battery/alternator test ;this should be done on an annual basis.. the "annual tune up"...

Day and night start up :: if the temperature is the same, then the only difference is the sunlight...and the solar heat effect... and maybe the length of time the car is sitting...
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the reply earthworm, as well as the welcome. How would I go about checking the ECU coolant temperature sensor? Where is it located? I wouldn't think it's the battery or alternator since the car starts normally most of the time, I haven't had an issue since it snowed last week. It's up in the 40s this week, and there hasn't been an issue. Thanks for the help.
 

·
Registered
Joined
·
21,583 Posts
1 - 4 of 4 Posts
Top