SaabCentral Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
Just working my way through a couple of issues with the new(ish) engine.


Seem to be getting a funny noise when putting the boot in and pressure goes past about 70%. Car seems to run extremely well otherwise.
I would describe it as a "tinny/shrill noise" , if that makes any sense. Its very consistent and doesn't occur until the pressure gets to about 70-75%. It is quite loud and it is disconcerting enough that I back off as soon as it occurs and I've gotten used to holding the throttle at just the right level so it doesn't push boost that high.
I think it is from turbo area (obviously I am driving, thats just where it seems to come from).


Had a very basic look for vac leaks. My gut is saying something is letting go/opening under the extra pressure but I'm not sure what. Maybe an issue with the bypass valve or wastegate but I dont really know what these would sound like if they had issues.


Hopefully there is something that is obvious to you guys, let me know your thoughts.
 

·
Registered
Joined
·
2,957 Posts
Make a video of it, usually its the normal sound of a dirty wastegate regulating boost, if it is whistling-like sound.
Boost leak, maybe, then u can only test for boost leaks.
Bypass valve would do a different sound, like when u driving without air filter, but u would definitely get a code for it.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #3
Sound isnt great sorry , is good on my phone but by the time its editted for youtube its pretty quite.
Hopefully you can hear something from this. (Its loudest from about 1 to 3 secs in)


 

·
Registered
Joined
·
283 Posts
Discussion Starter #5
No i havent looked that deeply at the turbo yet. (burying my head in the sand maybe). Although its funny that its very consistent noise. Hoping the wastegate might be flapping or something.
Will take a good look on weekend.
 

·
Super Moderator
Joined
·
20,202 Posts
Sorta sounds like an exhaust leak. A bad turbo bearing sounds like a dentists drill. Definitely check for in and out play on the wheel.
 

·
Registered
Joined
·
161 Posts
I've got a noise too when my turbo is under load, but it doesn't sound at all like yours. I just thought it was excess vibration from not marking where the passenger engine mount goes when I took it off. Did you by any chance remove and reinstall yours?
 

·
Registered
Joined
·
283 Posts
Discussion Starter #8
Very experienced turbo shop near me. Very nice guy had a quick look for nics, and he also watched the video. He says its definately not a turbo noise
.
He suspects I have a leak from the manifold (or maybe BPV which I do, but don't think its the BPV).
So I will follow it up a bit more when I get some time.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #10
Made a smoker ( I'll post it elsewhere ).
Its definately better than just pushing in air as I dont have to spray the bubbly stuff everywhere (not game to go above about 1psi though as I dont want it blowing up in my face).
Anyway, I and cant find any leaks vacuum or exhaust side except for the previously mentioned bpv/cover leak when I used just compressed air at a higher pressure. I might try replacing that as it needs doing anyway.
But I dont think thats the noise. I think if it is a leak, its only leaking at high pressure (>10psi boost) there is no sign of a problem until boost gets that high, and there is no other obvious symptoms I am noticing except for the noise.
 

·
Super Moderator
Joined
·
20,202 Posts
Like the other guy, I think it's somewhere in the exhaust stream.
 

·
Super Moderator
Joined
·
20,202 Posts
It's way upstream, like manifold area based on how loud it is.
 

·
Registered
Joined
·
10 Posts
The turbo shaft spins in excess of 200,000 RPM at full load.. Deffo not a turbo induced noise. Maybe check the flex pipe after your DP. If it's too long and/or too stiff (or rotted away) it may resonate.

Just a thought.




Sent from my Redmi Note 7 using Tapatalk
 
1 - 15 of 15 Posts
Top