SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Based on other reports of the radiator area being the cause I had a good look at mine yesterday. I could duplicate the slow speed rattle/knock by pulling on the intercooler-to-intake hose near the left hand upper radiator support bracket. I couldn't see exactly where the metal-to-metal contact was taking place but it went away when I pressed down on the radiator assembly at the upper mounting point. The fix is to bend the support bracket down about 3 to 5 mm. The radiator is spring mounted at the top so this preloads the support spring to keep the radiator from moving around.

So far, so good! :D Picture attached that shows the bracket in question.

Dave
 

Attachments

·
Registered
Joined
·
240 Posts
is this that noise that it makes when the clutch is engaging at low rpms? the kinda ka-klunk one? just wondering.. ive always kinda thought that was just the opti-flow intake bouncin around or something stupid like that..... Or what exactly is this sound you hear?
 

·
Registered
Joined
·
96 Posts
glfaholic said:
is this that noise that it makes when the clutch is engaging at low rpms? the kinda ka-klunk one? just wondering.. ive always kinda thought that was just the opti-flow intake bouncin around or something stupid like that..... Or what exactly is this sound you hear?
No, this noise sounds like clonk sound that comes from the front of the car,it sounds like suspension knocking and occurs when driving over slightly uneven road surfaces, i.e if you hit a drain cover or road repair. Most noticable at slow speeds, otherwise the road noise from the tyres hides it. Happens even if you coast along at say 5-10pmh with the clutch in, so not the same noise.

Brian
 

·
Registered
Joined
·
24 Posts
Front end rattle/knock

The rattle on mine is gone too,have this about 1/2 year now,and was near driving me cracy-and now it´s-GONE!!! :p :p :p

Thanks.

Heine.
 

·
Banned
Joined
·
82 Posts
what was the fix

hey heine what was the fix on it, i dont have that radiator thing, i looked but it seems like it is completely missing, help pls
 

·
Registered
Joined
·
130 Posts
DaVector03 said:
hey heine what was the fix on it, i dont have that radiator thing, i looked but it seems like it is completely missing, help pls
I found mine after taking off some plastic guard. I couldn't seem to press down hard enough with just my hand though. Anyone use a special tool? I was afraid of using a mallet and screwdriver.
 

·
Registered
Joined
·
155 Posts
ill have to check this on mine... just brought mine in for its 15,000 mile service - mentioned the sound to the guy and they said they couldnt duplicate it.... right. happens all the time to me.
 

·
Registered
Joined
·
1,840 Posts
Ive noticed this 'clonk' sound over the last two days. I though i cured it last night when i opened the bonnet (hood) to find my water blade sitting their from two weeks ago:lol: . But i heard the clonk once again this morning - hopefully this fix will sort it.
 
1 - 9 of 9 Posts
Top