SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter · #1 ·
Well past couple of days when i've gotten up to about 70-75mph i get a flashing check engine light, and did some research this suggests most likely a misfire issue. The DIC has been replaced in the past 15k miles so i assume it couldnt be that, is it a possibility it could be the CPS or something else? Any help would be greatly appreciated don't want to keep driving around :(
 

·
Registered
Joined
·
3,185 Posts
Try and count how many times it's flashing. Should be a pause between the flashing if it's a code. Mine has done it in the past and was something to do with the evap system. I managed to stop it by NOT tightening the gas cap all the way. Leaving it snug, but able to not not build up pressure. I doubt you have the same problem though as it's happening at higher speeds. Take it somewhere like Auto Zone and have any codes pulled (it's free). Then come back with the stored codes. It could be anything at this point.
 

·
Registered
Joined
·
276 Posts
Is the replacement DIC one of the cheap, Chinese made ones? If so, you definitely cannot rule out the DIC. How old are your plugs?
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #4 ·
I don't think its the gas cap, but yeah ill def have someone scan for codes soon (hopefully today). I know the DIC is fine no more than like 15k old and its a legit one not a bad DIC, i'm not sure how old the plugs are my first attempts later will be checking the plugs and vac lines for leaks.
 

·
Registered
Joined
·
1,499 Posts
I regapped my plugs and it didnt misfire anywhere near as bad. Given a couple days, it adapted and started to work almost like normal. I changed out the DIC, and no issues, but I'm not gonna tempt fate. I'm more concerned about my hot weather starting issues, when I got the fuel pump replaced at least a year and a half ago. Ugh...
 
1 - 5 of 5 Posts
Top