SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
I’m following the wis instructions to fit a new turbo on to my daughters 9-3 and I cannot for the life of me get the wastegate back on. The wis just says ‘fit the wastegate’ but actually there’s a coolant pipe that stops me from getting the wastegate far enough left to get the bolts into the holes in the turbo. Before taking off the wastegate on the new turbo I tried to fit it but was unable to line up the studs to the exhaust manifold holes as the wastegate was stopping me. I did watch a video where a guy lines it up without the studs and then puts them in from above with slots cut in them to screw them in to place but I shouldn’t have to do that. The wis is normally spot on if a little too many steps sometimes. I have tried the wastegate from the original turbo in case the bolts are a little shorter or something but it’s the same problem.
Anyone had a similar experience?

thanks in advance.
 

·
Registered
Joined
·
9,467 Posts
I'm wondering why the wastegate was taken off in the first place. I've replaced a couple of turbos on these cars, and I've always left the wastegate on. It's also far enough down on the front of the turbo that I can't see how it could possibly interfere with the manifold bolts.
 

·
Registered
Joined
·
17,377 Posts
I'm following here because I need to do this in the not-too-distant future. WIS definitely says to remove the wastegate and replace it. I don't know if that's required.

Looking at the TD04, I see only two bolts for the wastegate. Only has access mostly blocked by the cobra pipe but you could get in there if you had to without removing the cobra if it's already installed. The other is blocked by the A/C. Very tight. Ratcheting Combo probably gets in there too.

Do you have a GT17 or a TD04? GT17 might be different.
 
1 - 4 of 4 Posts
Top