SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
First of all for last couple months I hear squeaking noise when going over the bumps,found this video and it sounds just like mine (http://www.youtube.com/watch?v=eYQVG7mS1Pk). Also on low speeds or when taking off and turning wheel a cracking noise comes up. I have done some research and it appears that the problem is in strut mounts. I went to a car shop, they lifted the car up and after checking it told me that sway bar links need to be changed, not strut mounts. Also I recently put brand new tires and right after that car started to pull left a lot. I did an alignment, but it did not help.
So here is my question, do you think that problem only in suspension link or do I have to check something else too? I just want to find possible problems and repair all in one time and not go back and forth to shop to find the real cause. Thanks is advance.
Its an 04 9-3 with stock 15' wheels and 80000 miles
 

·
Registered
Joined
·
134 Posts
Suspension

Hello,

Well it is my second Saab and both of them do the same thing but in col temperature only. After driving the car to his normal temperature, it stop by itsefl. Never happen in summer time.
My first Saab (1999 - 9 3)was a bit pricey to maintain an I develop a good friendship with the mechanical guy, he teach me a lot of stuff for DIY. What he told me, regarding this issue is that even they change some parts in the suspension, I don't remember by heart the name of those parts but it wil eventually come back...
I lived with it, but if someone has a solution to provide !!!

Regards,
 

·
Registered
Joined
·
691 Posts
i talk with a saab tech last week and the problem is a ''sorry not sure the name but he show me'' sway bar under the car neer of the firewall...

saab told them in the past that you can take out the bar and put some ''special saab'' tape and it fix the problem for about a year (until the tape scrap..)

maybe its not really understandable what i said but i try my best..lol
 

·
Registered
Joined
·
290 Posts
My car did this only during winter and it is caused by the front suspension bushings. Mine were replaced and problem has been solved for over a year.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thanks guys, I guess I will live with this for now, since I had my car checked at a car shop and they did not find anything wrong besides sway bar links(which I already changed).
 

·
Registered
Joined
·
134 Posts
Front suspension bushings !!

Good morning,

adolan20...tell me how much did you pay to have replace the front suspension bushings. Does the car need to be realign after that part change ??

Regards,
 
1 - 7 of 7 Posts
Top