SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
It looks like my ABS unit is going out. After a few minutes of driving I get ABS, brake, TCS and triangle "!" warning lights on he dash. The speedo works. The breaks will also behave funny making a clucking noise until the warning lights come on then they work fine. I am assuming that is the ABS shutting off and just operating as power brakes.


I know about the mail order ABS module repair places. Is there a way to be certain it is just the ABS module and not the pump?

Is there a way to disable or bypass the ABS system since it operates fine w/ power brakes until I get the module repaired?
 

·
Registered
Joined
·
18,382 Posts
just read the codes!

Also make sure you have the same size tires, mine was like that when I ran 195/65/15 snows on one end and 195/50/15 (I know...) summers on the other.
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #5 ·
I guess i would need to go to a shop with a tech II in order to get those codes? I have OBDII but it is not picking up any codes.
 

·
Registered
Joined
·
511 Posts
You can simply unplug the module.
Of course you will lose ABS and Speedo abilities.

Brakes will work like a normal car though.
(I know because I did this myself)
 

·
Registered
Joined
·
2,176 Posts
The breaks will also behave funny making a clucking noise until the warning lights come on then they work fine.
Keep in mind, it could also just be an ABS sensor that's at fault.
I'll side with the faulty ABS sensor possibility. If one sensor is faulting, the ABS system can think you've got incipient wheel lock up and will flutter the valving to that wheel (that clucking noise you're getting).

Probably not the most elegant way to diagnose, but consider pulling a front and rear ABS sensor from a car in a breakers yard and swap the sensors out one at a time. Probably easier and less costly than getting a Tech 2 plugged into the system.
 

·
Registered
Joined
·
13 Posts
I have the same problem and it is the ABS sensor under right front wheel, my sensor is broken. Then I start the car and starting to brake pedal makes noises sometimes its hard to press and then ABS light shows problem with pedal stops, but ABS dont work anymore.
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #9 ·
Thanks guys. From your responses I feel strongly that it is a sensor. I have also been having some excessive wheel vibration coming from one or both of the front wheels which most like likely brought this on.
 
1 - 9 of 9 Posts
Top