SaabCentral Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1
2nd possible problem with my new car, I have the 1.9 TTiD and the fan is kicking in every few seconds and only last 3-4 seconds, is this normal? Does it before temp guage reaches running temp
 

·
Registered
Joined
·
8,889 Posts
You have low refrigerant and AC turns fan on/off.
 

·
Registered
Joined
·
158 Posts
Discussion Starter #4
The air con seems to be working perfectly, gets ice cold in seconds but the fan is on and off all the time, only kicks in for around 2-3 seconds then goes off again, no matter how warm the car gets the fan never comes on and stays on
 

·
Registered
Joined
·
8,889 Posts
Again: You have low refrigerant and AC turns fan on/off.
 

·
Registered
Joined
·
158 Posts
Discussion Starter #6
Ok, the A/C has stopped working completely now, it is not refrigerant level as I took it for a regas and it is full, any ideas why it's stopped working? Also the fan has stopped aswell
 

·
Registered
Joined
·
158 Posts
Discussion Starter #8
Any more details? Don't know what the UEC is ? where do I need to start checking? I've checked fuses and relay and there all ok
 

·
Registered
Joined
·
8,889 Posts
Use ohmmeter and check wires.
Remember to unplug battery first.
 

·
Registered
Joined
·
8,889 Posts
ECU connector B pin 94 - Fan relay box pin 5
ECU connector B pin 69 - Fan relay box pin 8
ECU connector B pin 90 - Fan relay box pin 4
 

·
Registered
Joined
·
158 Posts
Discussion Starter #14
Ok so I've put 12v over pin 5 and ground pin 6 and get a relay click, also same with pin 4 and 3 with a relay click, can't get either fan to run, checked the plug to the fan, 7, 6, 3 and 2 all have 12v, 5, 4 and 1 all have 3.4v, pin 8 is empty on the plug
 

Attachments

·
Registered
Joined
·
2,963 Posts
A bad A/C pressure sensor will do the same, or the fan module got burnt due cycling.
The answer is almost always Tech2, better than spending time on wiring ..
 

·
Registered
Joined
·
158 Posts
Discussion Starter #16 (Edited)
Thanks, I was actually suspecting pressure sensor as I had exactly the same thing happen on an Audi A4, is there any checks I can do without a tech2?
 

·
Registered
Joined
·
2,963 Posts
Its not the compressor, ur problem is A/C engagement, so it must be an input issue.
Inputs are temp, pressure, A/C demand and ECM cut due certain faults (overheating, fan issues ...etc)
 
1 - 20 of 22 Posts
Top