SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1 (Edited)
Experiencing extreme rough idle, car fails to start 1/5 times, check engine light on.

The problem occurred my on morning drive to school which is 10 mins city driving. The car had been working fine beforehand , never had any idle issues. I noticed that morning while warming up the car I felt a 3-5 misfires , I drove along to school and I was approaching a hill so I gassed it and all of the sudden the engine felt like I was running on 2 cylinders. Heavy misfire and hesitation, it was so bad I had to park the car and catch a ride. I have been using Lucas gas treatment 3 tanks in a row.

However I came back 7 hours later and started the car , ran smooth! Halfway back to the house the car acted up. Towed car to friends house and then...

Upgraded to TD-04, replaced spark plugs,fuel filter,performed engine flush and removed small quantity of sludge,throttle body coolant by pass, new PCV version,installed a new rubber antenna:cool:.

Started the car, wow amazing performance however after 10 mins of driving the car it stalled,failed to start once,rough idling came back( just as bad as the 1st encounter).

I thought of CPS,MAF,O2 sensors,Throttle Body,DIC,bad gas?

The DIC emits spark as I tested it out by plugging the sparks in and grounding them with a wire, crank and all four cartridges fire. BUT, looking at Chamber #4, there appears to be a small amount of fuel coating the piston left unburnt.

Leave the car alone for a few hours start it back up and it idles fine (in park) until you REV the engine or give it load it goes back to the same issue.

Here is a quick video of proper revving and then a stall and a delayed start with a crank. Notice the noise is engine tap not misfire on the 1st run. http://www.youtube.com/watch?v=Zh9W9EW4nhI

I do not have a code reader at the moment.
What is going on?
 

·
Registered
Joined
·
21,583 Posts
Good on doing the service work.:cheesy:
Now to the troubleshooting.
A failing CPS , when cold may yield good readings, when warm to hot, it will cause the engine not to run.
A failing O2 sensor, the lambda unit, will trigger a CEL and the MPG will drop. The engine will continue to run, as the ECU will go into default.
The MAP ? I do not know.
We do seem to have a weak spark.:eek:
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Good on doing the service work.:cheesy:
Now to the troubleshooting.
A failing CPS , when cold may yield good readings, when warm to hot, it will cause the engine not to run.
A failing O2 sensor, the lambda unit, will trigger a CEL and the MPG will drop. The engine will continue to run, as the ECU will go into default.
The MAP ? I do not know.
We do seem to have a weak spark.:eek:
It cannot be the lambda unit for the car has always had great MPG, and it will not cause the car the react this way.

The CPS is something I feel strongly about because of the symptons, especially if you were to know the symptoms of a failing CPS, http://en.wikipedia.org/wiki/Crankshaft_position_sensor scroll to the very bottom.

I am also pulling to the weak spark, it catches my attention. Is there a way to effieciently test the DIC? I've tried calling shops to let me borrow one on deposit but no results.

So 2 things, CPS and DIC... I feel like I'm running circles with this car. If anyone can repair Saabs , they can fix anything.
 
1 - 3 of 3 Posts
Top