SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi,

My 2004 Saab 9-3 Arc convertible has always had more exhaust smell than normal in the cockpit, but it's gotten worse recently. Also, it's recently been idling quite roughly on cold starts.

I'm currently at a muffler shop and they're checking for exhaust leaks. I'll see what happens.

I've heard some later cars burn valves, but I did a compression test and everything look good, 200 - 210 psi on all cylinders. I changed the plugs while I was at it. I also checked the intake hose that I understand can crack and cause idle problems. The engine isn't throwing any codes and has about 120,000 miles on it.

Any ideas?

Thanks,
Eric
 

·
Registered
Joined
·
2,943 Posts
check misfire counters, and based on what clyonder is misfiring try to swap coils to see if misfire moves between cylinders.
Depend on the exhaust leak location it could affect the car running if its before the catalytic converter .
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
check misfire counters, and based on what clyonder is misfiring try to swap coils to see if misfire moves between cylinders.
Depend on the exhaust leak location it could affect the car running if its before the catalytic converter .
The muffler shop said that there was definitely an exhaust leak, but thought it was around the turbo area and said that I should contact someone who worked on Saabs. I've got an appointment with a local Saab specialist.
 

·
Registered
Joined
·
161 Posts
Just throwing out a possibility - did you ever remove the turbo or remove the cat from the turbo? If where the turbo and the cat mate is not seated properly, you can get a tiny exhaust leak from there. I believe your O2 sensor #1 would register that.
 

·
Registered
Joined
·
182 Posts
So, while I was and still am trying to chase and electrical problem, I noticed that I had a blown fuse. #35 40 amp Maxi in the under hood fuse box. This controller a secondary air pump which is located on the driver side frame rail. Had the same type of problem. When I would start my car in the morning, it would smell like it was running rich. When warmed up ,all was good. Replaced the fuse and the air pump started working again and no smell.
2006 9-3 Anniversary Special
 
1 - 6 of 6 Posts
Top