SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2005 Saab 9-5 all lights came on the dashboard, everything went haywire and A/C buttons weren't working but it was blowing air. I pulled over, turned the car off thinking it might reset and it wouldn't turn back on. Just replaced the alternator, has new battery, and had the ABS module inspected with nothing wrong. Any suggestions?
 

·
Registered
Joined
·
2,395 Posts
2005 Saab 9-5 all lights came on the dashboard, everything went haywire and A/C buttons weren't working but it was blowing air. I pulled over, turned the car off thinking it might reset and it wouldn't turn back on. Just replaced the alternator, has new battery, and had the ABS module inspected with nothing wrong. Any suggestions?
How was the ABS module inspected? Usually the internals fail, and the only way to inspect that would be to cut it open.

However, your problem doesn't sound like ABS module anyway. It sounds like maybe a loose ground wire to me, but I'm sort of just guessing.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I sent it into Module Master last week and they called today to let me know there was nothing wrong with any of the connections. Thanks for the idea!
 

·
Registered
Joined
·
614 Posts
Belay my last. Just re-read your post and noticed the new battery. Might still want to check the condition of that new battery with the load test.
 

·
Registered
Joined
·
553 Posts
Doesn't sound like an ABS situation, but a dodgy brake-light pedal switch (dirty contact) can create the Xmas lights effect as well.
 

·
Registered
Joined
·
478 Posts
Plus 1 on brake light switch cleanup

I planned a replacement of the brake pedal switch (and there are two, non-identical).

I ordered and recieved a Facet brand part, shown as correct fitment by vendor to replace the left switch (on automatic trans car). I installed it, but it didn't work - I have since found that the contact setup on that switch is exactly backward of the SAAB part.

With no other same-day option, I cleaned and reinstalled the old switch, and it has worked fine for more than a year.
 
1 - 7 of 7 Posts
Top