SaabCentral Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
I change the spark plugs today and saw this valve that was not connected. I did a little bit of research and figured that it may be the ETS Non-Return Valve.

Do anyone know exactly what this does, and how my car would run without it attached? This may be the root of my issues perhaps.


 

·
Registered
Joined
·
137 Posts
Do you have a V6?

I had something similar happen just recently as well! I'm not sure since you have two pictures with one hose removed in the first, and 2 in the second (unless I am misunderstanding). It looks like that is a one way check valve, for lack of a better term, a PCV valve (read more on the thesaabsite under 9-5 V6 Emissions and Related- it explains that its not truly a PCV valve). The one-way should be pointing to the TB. Mine was attached to a 90 degree elbow rubber hose (smaller than the other 2 that connect to the TB).

I'm assuming since my valve looks in much worse shape than yours, that I was running for quite some time without it. Since I've replaced it, the car seems to run smoother.
 

·
Registered
Joined
·
693 Posts
Hmmm.. if you're referring to the nipple on the right (on the TB) I never knew what that was called. Only that it's capped off on my car.
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #5 ·
Do you have a V6?

I had something similar happen just recently as well! I'm not sure since you have two pictures with one hose removed in the first, and 2 in the second (unless I am misunderstanding). It looks like that is a one way check valve, for lack of a better term, a PCV valve (read more on the thesaabsite under 9-5 V6 Emissions and Related- it explains that its not truly a PCV valve). The one-way should be pointing to the TB. Mine was attached to a 90 degree elbow rubber hose (smaller than the other 2 that connect to the TB).

I'm assuming since my valve looks in much worse shape than yours, that I was running for quite some time without it. Since I've replaced it, the car seems to run smoother.
It is a V6, and the valve looks to be ok, I think it would just be the hoses I need.

you're saying the one was should be pointing right?
 

·
Registered
Joined
·
137 Posts
Did you remove any hoses? I can take pictures when I get home to show you how mine looks, since it's hard to tell from your pics - there is a longer hose that connects that valve to another part in the engine bay (forget where exactly off the top of my head) and a short elbow on the TB, with that valve in between. The valve in your picture is sitting about where it should be, but connected on each end, and laying on its side - obviously. :cheesy::p:cheesy:
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #7 ·
I took off the cover to change spark plus and this is what it is like in the first picture. it is idling really rough and sounds like it is misfiring. The PO probably took it into some shop and the noobs screwed it up. However it does seem like it is hard to find repair guides for this car..
 

·
Registered
Joined
·
137 Posts
This is what mine looks like:
The first pic is from the angle you seem to be showing, and the second one shows where it goes more or less underneath the area (small hose on right), and the last is a side shot showing where it goes and disappears into the second pic (follow from the valve back). Sorry if that's confusing.

Also, it looks like you're missing a cap on your TB (see first pic).
 

Attachments

·
Registered
Joined
·
60 Posts
Discussion Starter · #9 ·
This is what mine looks like:
The first pic is from the angle you seem to be showing, and the second one shows where it goes more or less underneath the area (small hose on right), and the last is a side shot showing where it goes and disappears into the second pic (follow from the valve back). Sorry if that's confusing.

Also, it looks like you're missing a cap on your TB (see first pic).
It is mildly confusing but that you so much. I think this solves my little problem, now i need to hope i get a chance to check that out tomorrow. this may be it. i need to find that hose though..
 

·
Registered
Joined
·
137 Posts
Can you see through it? If so, then it's no good. It has a spring actuated membrane inside. Also you can try blowing through it. If you can blow one way but not the other, then it's working as intended.

Did you find all of your hoses/caps?
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #12 ·
Can you see through it? If so, then it's no good. It has a spring actuated membrane inside. Also you can try blowing through it. If you can blow one way but not the other, then it's working as intended.

Did you find all of your hoses/caps?
The valve still seems good, but I have seen people with seemingly good valves that are actually bad.

I would like to get some new hoses though and some hose clamps. are these 5/32 hoses? Can I just buy some new silicone hoses and replace them, or do they have exact fit kits for these? I also need to find that cap that goes over the other nozzle..

I have 2 cars that I'm working on and i just want everything to work now.
 
1 - 12 of 12 Posts
Top