SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Well I have a idle problem some times the car will idle very erratic like from 1000 to 2000 for about a minute and then will settle down to normal. Just took her out for a rip and the idle was erratic again and then would stay at around 1500 and between shifts the rpms stay high ? Also first gear pulls very well
But 2 and 3rd seem very soft. The gauge is saying full boost but dose not have the pull as first? Could this be a vacum leak? Just put new plugs and a new cps ?
Any input would be great thanks
Jamie
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
Will do thanks

What size are the lines would like to replace all off them. Would just any vacuum line work from napa or no? This erratic idle started after I took the tb off and cleaned it so I hope this is the problem
Thanks
 

·
Registered
Joined
·
18,906 Posts
You might have a leak at the o-ring where it mounts. Check the other hoses that connect to the TB. You might need to clean your IAC valve, but it seems unlikely that it would go dirty at the same time you cleaned the TB.

You can use 5/32 line vac from NAPA.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
O ring

Were can I get a new tb gasket no one seems to be able to get me one. Can I just use some gasket sealer or rubber gasket?
Thanks
 

·
Registered
Joined
·
398 Posts
Were can I get a new tb gasket no one seems to be able to get me one. Can I just use some gasket sealer or rubber gasket?
Thanks
I used the black gasket sealing gunk/stuff (I know, real descriptive) on mine and it helped a lot. I only did it because I had some left over from doing a gasket on my brothers Daewoo :eek:

Otherwise, take your o-ring to an auto parts store, you can find one that will fit pretty easy.
 
1 - 6 of 6 Posts
Top