SaabCentral Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
We just bought this car (102000 miles) last weekend for my daughters friend that recently moved in with us after her Eclipse timed out! We were just trying to help her out and this car has codes and were afraid for her to drive back and forth to college. The codes are as follows.
Po300 - random multiple cylinder misfire
Po301 - misfire Cyl #1
Po202 - Same as above, but Cyl#2
Po203 - Same as above, but Cyl#3
Po245 - Injector waste gate solenoid "A" low.
We cleared the codes but they came back.
It seemed to run fine even tho the engine light was on.
She hasnt driven it much but today on her way home from town she stopped at a light and it started running bad and the engine light was blinking. Shortly after it started running fine again.
We could use all the help we can get. :cry:
 

·
Registered
Joined
·
12,509 Posts
Do not drive the vehicle if the CEL is flashing.. you are destroying your Catalytic Converter for one. You need to get towed to a Shop and get Diagnostics done... possibly an Injector and or ECU issue with the multiple codes your getting.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
update

changed plugs cel is off...drove car approx 20 miles..no cel...checked for codes anyway ..now it has codes
245 turbo wastegate solenoid a low
201 injector circuit malfuntion cyl 1
202 injector circuit malfuntion cyl 2
203 injector circuit malfuntion cyl 3
204 injector circuit malfuntion cyl 4;oops:

car seems to run fine...just know the codes are there..only owned it for a week...cant seem to get to the bottom of it..help
 

·
Super Moderator
Joined
·
9,348 Posts
Welcome to SC..

remove the black engine cover & check all the wiring & earths are nice & tight underneath it..
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
thanks i will check! anyone have any other ideas?

originally had codes of 245, 301 201 202...changed plugs cleared cel and car runs great? no cel but i checked for codes anyway...still has 245 which is turbo wastegate solenoid low and it has changed from misfires random misfire codes to p0201 202 203 and 204 which are all injector circuit malfunctions. where do i start?
 

·
Registered
Joined
·
26 Posts
maybe also check the connector and loom to the ionisation detection module? This looks like a bunch of cables leading to a square cable connector located above the vacuum pump
 

·
Registered
Joined
·
26 Posts
Just looked the codes up in WIS.

P0245 - Boost Pressure Control Valve Circuit. Open / Short to Ground

Maybe check the connector to the charge air valve is made correctly? It looks like this code is only generated when the valve is bad or there is a short to ground
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
thanks for all the help...she took the car car to her dads mechanic and he did several checks..when he finished the radio will not come on...then after driving the car approx 60 miles round trip to college she turns it off and then it wouldnt start. put a new battery on and it started right up..still no radio though..think the mechanic shorted something?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
oh...anyone want to buy a 2003 saab arc 9-3 with 102k on it? i will sell it for what i have in it...kbb is 5700.00 will set it today for 4700.00. it is extremely clean loaded car! just tired of the codes..
 

·
Registered
Joined
·
134 Posts
i have the same problem in my 2003 saab 93. changed spark plugs, injectors, coils, and problem still consists. can somebody please help...
 

·
Registered
Joined
·
13 Posts
saab 9-3

i have the same problem in my 2003 saab 93. changed spark plugs, injectors, coils, and problem still consists. can somebody please help...
hey i was just wondering if u got your saab fixed,im having the same problem and going crazy trying 2 find whats wrong plz say u have a answer thanks marcus
 

·
Registered
Joined
·
13 Posts
saab 9-3 problems

changed plugs cel is off...drove car approx 20 miles..no cel...checked for codes anyway ..now it has codes
245 turbo wastegate solenoid a low
201 injector circuit malfuntion cyl 1
202 injector circuit malfuntion cyl 2
203 injector circuit malfuntion cyl 3
204 injector circuit malfuntion cyl 4;oops:

car seems to run fine...just know the codes are there..only owned it for a week...cant seem to get to the bottom of it..help
im having the same problem with my saab same codes and everything how did u fix your thanks plz reply back im going crazy and broke
 
1 - 16 of 16 Posts
Top