SaabCentral Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 · (Edited)
Alright so I have a 2000 9-3 that we got last year and has 187,000 miles on it. its my first car (i'm 17) and the car is my baby. we've never had too much trouble with it besides some front suspension issues which we were able to resolve. we dropped the oil pan and cleaned the screen and we did the upgraded air box system. lately the engine hasn't seemed to be running as quick and seems to sputter/Misfire when I hit the gas hard. the only thing we've done to the engine is replace the hydraulic mount and do the air box however we managed to break one of the injectors slightly at the little plastic clip that seats the injector (the part closest to the engine) after ordering the wrong injector twice we were able to get the injector to work but it seems to be running worse since. There's a small oil leak somewhere as well that we haven't pin pointed. What does the issue sound like to you guys is it not sparking and needs new coils? or is it the injector? or could the leak be causing low oil pressure and putting me in limp mode? Any help is Greatly appreciated as this car is a learning experience for me and I cant afford to go replacing every part that could use some replacing. Thanks in advance!
P.S. we also replaced 2 vaccum hoses
P.p.s. Engine light has always been on we think it's an Evap sensor but the light flashes when the engine misfires
 

·
Registered
Joined
·
19,382 Posts
Your flashing light is usually known as "catalyst damaging misfires". If it's been happening a lot, you may have killed your cat converter.

Go to Autozone and get the code read, or buy a reader for $50 and DIY.

Misfires, if that's what it is, are usually either an injector issue, a bad plug(s), or a bad DIC. Normally around here it's the second two. But, if your problem started after replacing the injector, I suspect that might be the issue.
 
1 - 3 of 3 Posts
Top