SaabCentral Forums banner
1 - 3 of 3 Posts

· Registered
17 Posts
Discussion Starter · #1 ·
I've got a '99 9-3 which is experiencing a sudden and random loss of engine power.

I've been trying to debug it myself over these last few weeks, but after having to abandon a road trip home to Canada for Christmas while still in WY I realised I need help!

  • Engine appears to lose power in a sudden, binary way - this happens randomly, isn't a function of temperature or load.
  • When there's a power loss the rpm on the tachometer will slowly drop and occasionally the car will recover and start again on its own. The rest of the time it won't and I have to pop it into neutral, move the key to 'OFF' position and the restart. Doing this while going 85 mph in WY isn't fun... gf was not impressed..
  • Upon restarting its as if nothing has happened, turbo spools up no problem and she's good as new.
  • During a power loss, all electrical systems work fine- radio, lights etc. If the power loss happens at idle I can hear the fuel pump continue to work for a few seconds after the rpms have dropped.

Other information:

  • I've recently replaced the spark plugs and fuel pump and fuel filter.
  • Battery has been tested, and is up to spec and the alternator is producing 14.1 V of charge
  • No check engine light or codes showing up on ODBII reader
  • I have a spare stock ECU left over from my T7 BPC conversion, swapped this in, and no change in symptoms
  • Spare DI also shows no change.
  • I pulled the CPS and found a 4mm chunk of metal stuck to it (the CPS has a magnet inside) - swapped in a spare CPS which is known to be in good working order, and again no change in symptoms.
  • Wiggling key in ignition to try and test ignition switch connectivity doesn't change behaviour
  • MAP sensor is relatively new ~ 2 years, swapped w/ spare, no change.
  • 1999 9-3S Auto w/ 180K, T7 BPC, Viggen intercooler

Initial thoughts-
At first I thought this was a CPS problem - I've read other forum threads where it seems if the ECU detects a poor/no signal from the CPS it will cut fuel, when the signal is restored, then the ECU opens up the injectors again. This would seem to match with what I'm seeing, but swapping the CPS gave no change...

My next step it to take a look at the ignition switch based on what I've read on this forum and others, but I'm doubtful.

Other ideas - ignition relay? O2 sensor? Fuel pressure? Ground problems?

Any help here would be greatly appreciated.

Thanks - BDRSaab

· Registered
17 Posts
Discussion Starter · #2 ·
Here's a pic of that metal chunk I found sticking to my CPS.

Still no change - engine dies randomly, tach and electrics function OK. Still will restart on its own if I'm at highway speed. No CEL or ODBII codes.

I'll try and look at the ignition switch when the weather warms up.

Any other ideas out there?


· Registered
17 Posts
Discussion Starter · #3 ·
I did eventually figure out what was going on - thought I might document it in case someone out there finds this useful.

The culprit was a bad MAP sensor. It apparently would send wrong signals to the ECU and while this wouldn't cause it to throw a CEL, when I replaced it with a unit borrowed from my '95 9000 Aero the problem went away.

So - moral of the story - even if the part is relatively new (I had replaced the MAP sensor previously with a brand new unit) it can still fail!

Hope this helps someone -

1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.