SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a '97 900s automatic. The engine while driving will intermittently lose power then continue going and at every stop or slow turn lose power when accelerating. Sometimes stalls on acceleration from stop. Car always turns right back on. I have cleaned the AIC and tried disconnecting the hose from the evap purge valve and plugging the hose connected to the throttle body. No fix. I can't find any leaks or cracks in the vacuum hoses. Idle is fine since cleaning the AIC. I'm thinking it is the fuel pump, but wanted to get someone else's opinion before letting a mechanic take me to the bank. Thanks.
 

·
Registered
Joined
·
21,583 Posts
I have a '97 900s automatic. The engine while driving will intermittently lose power then continue going and at every stop or slow turn lose power when accelerating. Sometimes stalls on acceleration from stop. Car always turns right back on. I have cleaned the AIC and tried disconnecting the hose from the evap purge valve and plugging the hose connected to the throttle body. No fix. I can't find any leaks or cracks in the vacuum hoses. Idle is fine since cleaning the AIC. I'm thinking it is the fuel pump, but wanted to get someone else's opinion before letting a mechanic take me to the bank. Thanks.
Could be the fuel pump, could be the CPS...
Miles ???
Starting time ( should be a second or two) ??
Engine compression ? (at least 140, with a 10% variance)
Warm up time ??? ( in this heat - 2 minutes)
Fuel pressure ?? (maybe a good indie-mechanic can do this ??)
Stalling during acceleration is indicative of fuel pressure shortage..
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Car has 145,000 miles. Car starts right up no problem. Car has no problem warming up. I will take to my mechanic and have him take a look then. Thank you for the response.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
codes I pulled

I went to Autozone to get the codes pulled. I got 5 and looked them up online since Autozone couldn't find what they meant for Saab. P0341 for camshaft position sensor A Circuit range/performance (bank 1 or single sensor). P0335 crankshaft position sensor A circuit. I'm guessing both these are because of a bad cps and I plan to change it. P1127 multiplicative adaption, bank 1 min. valve. Not sure about this one, but I think it has something to do with the next code. P1140 MAF or TP sensor malfunction. I'm going to try and clean the mass air flow sensor. I will look up the throttle position sensor and see about that. last P0115 engine coolant temperature circuit. Not sure where this is or what it could mean. Any advise would be appreciated.
 
1 - 4 of 4 Posts
Top