SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
So got on the highway yesterday and while changing from 2nd to 3rd my engine light started flashing. Went away after 15-20sec then about 25m later came back on for the rest of the trip out. Engine seemed fine and I made it fairly easy (pushed it up to 85mph to test it at one point, otherwise took it easy). The turbo, on the other hand, refused to push past the mid point in the orange. Anyone out my way with a tech2 willing to meet for a quick code pull or knows of a mechanic around Hampton Bays area open on Saturday? If not I'm off to Pep Boys (bleh!). Engine still turns over and is drivable btw, would also appreciate any theories.
 

·
Registered
Joined
·
239 Posts
Sounds like the car went into limp home mode. One common reason is a slight buildup of carbon in the throttle body. You'll know once you get the code read. If it's the throttle body code, you can easily clean it with throttle body cleaner and there's a good video on youtube about how to reset the throttle body.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
Pretty spot on with the throttle body. Code came up: "P0101 (MAF) Mass Air Flow or (VAF) Volume Air Flow Sensor - Circuit Range Performance Problem." The longer printout states "DTC indicates leak between mass air flow sensor and throttle body or fault in mass air flow sensor."

So, looks like I'll try getting in there to clean out the throttle body and then pull the MAF sensor and give that a cleaning. I'm assuming I can go by this DIY for the MAF? (http://www.saabcentral.com/forums/showthread.php?t=207286)
 
1 - 4 of 4 Posts
Top