SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a T reg 9-3 2.3i with about 97k on the clock.

Very recently it has started suffering from what feels like a lack of power and also on acceleration will rev without any real effect before the revs drop and then the power seems to increase.

This happens both from cold and when warm and sometimes the revs even drop (maybe 3-400 revs) without any action from me and then they return to normal again.

Any known problems that I should be looking out for ???

Cheers
Paul
 

·
Registered
Joined
·
21,583 Posts
Reading, as in Reading, PA ?

And Welcome to SaabCentral, Psheen

We seem to have several things here.

The annual service , has this been done ?

The clutch seems to be slipping and badly. I am surprised that there is no report on a burned clutch disk.

Has the IAC been cleaned and lubricated ? (part of the service)
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi ther eand thanks :) But no, its Reading UK.

It was serviced about 10 months ago.

We don't believe its the clutch slipping (although prepared to be wrong!!) as when we park up and apply the handbrake then put the car in gear and release the clutch it starts to move slowly forwards.

As for the IAC (I don't know what this is :confused:) it's certainly not been done since the next service.

Would a burned clutch disc show up on the warning display?
 

·
Registered
Joined
·
917 Posts
Try starting from a standstill in third gear....if you manage to get it going, you have a worn clutch. A good one will make the car shudder and stall.
 
1 - 4 of 4 Posts
Top