SaabCentral Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I have some assorted problems with my 94 900S. 2.3L five speed.

Main:

--Starting: Sometimes, the car won't start. It almost seems that if I unlock the car first from the passenger side, that it disables starting. Also, If I stall the car, or am trying to teach someone to drive a stick, I have to turn the car off and then back on.

--Stalling: Randomly, the car will just shut off. Again, I have to turn the car off and then start it again. It does this while I am driving, and usually after I have taken the car out of gear into neutral to slow down.


--Check Engine Light: This is extremely sporadic. It seems that the light comes on if it is cold out, and that the temp gauge doesn't rise. It also will go on and off after it comes on while I'm driving somewhere. Usually, this happens at night time. Where should the temp needle stay when at full operating temperature? Sometimes mine will go to a 1/4 or to just a hair over 1/2. Thermostat?



Random:

--Lights: Frequently, the front light failure warning comes on when I turn the high beams on. The driver side high beam is out, yet the bulb is good. And as of the other day when I put new headlight assemblies in, I get a front light failure warning for no apparent reason. My turn signals work and my headlights work.

--Heated seat: My passengers have said the passenger seat is hot. I can't feel anything on mine.



All help is appreciated.
 

·
Registered
Joined
·
2,490 Posts
ok the starting problem and the stalling problem might be related to the CEL you should get it checked at an autozone or something

heated seat could be a relay,fuse, or a bad switch,
High beam is due to the relay solder joints going bad you can try to giggle it or something to make a better connections to the main prongs.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #3 ·
My car is OBDI and the code scanners do not read my car.
 

·
Registered
Joined
·
411 Posts
First, change the thermostat. That should fix the temp gauge.

Find the orange relay under the hood and pull it out. Take the cover off and inspect the connectors inside the relay. You'll probably see some small cracks in the solder. Take a soldering iron and remelt the connections without shorting any of them out. Replace relay. High beams only work if the switch is turned to the on position for lights. Daytime running lights (DRL) won't give you high beams. I mention this 'cause it's something I forgot on my car.

I know nothing about the seat heaters but I bet you could unplug them or the relay.

Best of luck.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #5 ·
I do have my headlight switch on. I am driving at night when this happens and I need to use my high beams, say on a country road.
 

·
Registered
Joined
·
21,583 Posts
I have some assorted problems with my 94 900S. 2.3L five speed.

Main:

--Starting: Sometimes, the car won't start. It almost seems that if I unlock the car first from the passenger side, that it disables starting. Also, If I stall the car, or am trying to teach someone to drive a stick, I have to turn the car off and then back on. Possible problems with the central locking system, as a guess.
I'd try to bypass or completely remove it as they seem to become so unreliable in an older car.

--Stalling: Randomly, the car will just shut off. Again, I have to turn the car off and then start it again. It does this while I am driving, and usually after I have taken the car out of gear into neutral to slow down. Clean and service the IAC as necessary.

http://pages.infinit.net/mlbriand/saab/iac/page1.html

--Check Engine Light: This is extremely sporadic. It seems that the light comes on if it is cold out, and that the temp gauge doesn't rise.
http://www.saabcentral.com/forums/showthread.php?t=110777
http://www.saabcentral.com/~munki/technical/engine/electrical/cel_codes_motronic.htm
It also will go on and off after it comes on while I'm driving somewhere. Usually, this happens at night time. Where should the temp needle stay when at full operating temperature? Sometimes mine will go to a 1/4 or to just a hair over 1/2. Thermostat?
Have the codes read, frequent your local friendly indie mechanic; you have the older OBD1 1 system..
Thermostat , the car should be fully warm within 4 to 6 minutes from cold. The temperature should then be pointing to 9 O'Clock (in the middle). Your t-stat seems to be shot. This is a regular service item, renew every 3 to 5 years.



Random:

--Lights: Frequently, the front light failure warning comes on when I turn the high beams on. The driver side high beam is out, yet the bulb is good. And as of the other day when I put new headlight assemblies in, I get a front light failure warning for no apparent reason. My turn signals work and my headlights work. another "orange relay" failure, break out your soldering gun.

http://www.customsaab.com/forum/viewtopic.php?t=61

--Heated seat: My passengers have said the passenger seat is hot. I can't feel anything on mine. Its works not, maybe its a shot thermostat.



All help is appreciated.
Bring all of the required servicing up to date, this includes the full battery/charging system service.
 
1 - 6 of 6 Posts
Top